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SOFTWARE LICENSE 
PLEASE READ THIS DOCUMENT CAREFULLY BEFORE USING THIS SOFTWARE.  YOU AGREE TO BECOME BOUND BY THE 
TERMS OF THIS LICENSE.  IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DO NOT USE OR INSTALL THE 
SOFTWARE AND PROMPTLY RETURN ANY MATERIALS TO AVERY DENNISON CORPORATION FOR A FULL REFUND IF 
PURCHASED. 
The enclosed computer program(s) ("Software") is licensed, not sold, to you by Avery Dennison Corporation ("Avery Dennison") for use 
only under the following terms, and Avery Dennison reserves any rights not expressly granted to you.   
 
1. License.  This License allows you to: 
(a) Use the Software only on a single computer at a time, except that the Software may be executed from a common disk shared by 
multiple CPUs provided that one authorized copy of the Software has been licensed from Avery Dennison for each CPU executing the 
Software. 
(b) Make one copy of the Software in machine-readable form; provided that such copy or the original may be solely for backup purposes.  
The Software is protected by copyright law.  As an express condition of this License, you must reproduce on each copy the Avery 
Dennison copyright notice and any other proprietary legends on the original copy supplied by Avery Dennison.  This restriction on copying 
the Software expires upon the expiration of all underlying copyrights. 
(c) Transfer the Software and all rights under this License to another party together with a copy of the License and all written materials  
accompanying the Software, provided you give Avery Dennison written notice of the transfer and allow Avery Dennison a reasonable time 
to object to such transfer and the other party reads and agrees to accept the terms and conditions of the license and provides confirmation 
to Avery Dennison. 
 
2. Restrictions.  You may NOT distribute copies of the Software to others or electronically transfer the Software from one computer to 
another over a network.  The Software contains trade secrets and you may NOT decompile, reverse engineer, disassemble, or otherwise 
reduce the Software.  YOU MAY NOT MODIFY, ADAPT, TRANSLATE, RENT, LEASE, LOAN, ENCUMBER, RESELL FOR PROFIT, 
DISTRIBUTE, NETWORK, OR CREATE DERIVATIVE WORKS BASED UPON THE SOFTWARE OR ANY PART THEREOF. 
 
3. Termination.  This License is effective until terminated.  This License will terminate immediately without notice from Avery Dennison if 
you fail to comply with any of its provisions.  Upon termination you must destroy the Software and all copies thereof, and you may 
terminate this License at any time by doing so. 
 
4. Export Law Assurances.  You agree that neither the Software nor any direct product thereof will be transferred or re-exported, directly or 
indirectly, into any country prohibited by the US Export Administration Act and the regulations thereunder or will be used for any purpose 
prohibited by the Act. 
 
5. Warranty Disclaimer, Limitation of Remedies and Damages; 
THIS SOFTWARE AND THE ACCOMPANYING WRITTEN MATERIALS ARE LICENSED "AS IS".  IN NO EVENT WILL AVERY 
DENNISON, OR ITS DEVELOPERS, DIRECTORS, OFFICERS, EMPLOYEES, OR AFFILIATES BE LIABLE TO YOU FOR ANY 
CONSEQUENTIAL, INCIDENTAL, OR INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS 
INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OF OR INABILITY TO USE THE 
SOFTWARE OR ACCOMPANYING WRITTEN MATERIALS EVEN IF AVERY DENNISON OR AN AUTHORIZED AVERY DENNISON 
REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  AVERY DENNISON DOES NOT WARRANT 
THAT THE SOFTWARE WILL FUNCTION PROPERLY IN YOUR MULTI-USER ENVIRONMENT. 
BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR 
INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU. 
Avery Dennison's entire liability and your exclusive remedy shall be, at Avery Dennison's option, either (a) return of the price paid or (b) 
repair or replacement of the Software that does not meet Avery Dennison’s specifications and that is returned to Avery Dennison with a 
copy of your receipt. 
COPYRIGHT 
©2015 by Avery Dennison Corporation.  All rights reserved.  No part of this publication may be reproduced, transmitted, transcribed, stored 
in retrieval system, or translated into any language in any form by any means without the written permission of Avery Dennison 
Corporation. 
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I N T R O D U C T I O N  
Welcome to Avery Dennison® PCMate™ Platinum.  There are four software modules 
in PCMate: Print Module, Design Module, Print Preview Module, and Macro Editor 
Module.  
This manual provides information about PCMate’s Design Module and Macro Editor 
Module.  For information about the Print Module and the Print Preview Module, refer to 
PCMate’s Label Printing Guide. 
In this chapter, you can learn 
♦ about the documentation. 
♦ how to get help. 
For information about the Macro Editor Module, see Chapter 9, “Working with Macro 
Lookups.” 

A b o u t  t h e  D o c u m e n t a t i o n  
This manual describes how to use PCMate Platinum v7.5.  If you are using a different 
version of PCMate, the information in this manual may vary slightly. 
This manual uses consistent text formats.  The table below lists the typographical 
conventions used and provides a description of each convention. 
 
Convention Description 

Bold Words that are bold are the names of actual menu items, l ist boxes, 
text boxes, buttons, column headings, and tab labels in the software. 

Italic Words that are italic are names of windows, frames, and dialog 
boxes. 

UPPERCASE & BOLD Words that are uppercase and bold are items you should type into a 
text box or on a command line. 

UPPERCASE Words that are uppercase are keys on the keyboard or acronyms.  
When two or more words in uppercase appear together with a plus (+) 
sign in between, press all of the keys at the same time.  A comma (,) 
indicates you should press and release the keys one after the other. 

Note A note contains information that explains why you are doing 
something, or offers further reference information for the task at 
hand. 

WARNING A warning alerts you that what you are about to do may endanger 
computer devices, operating software, or data. 

 

G e t t i n g  H e l p  
Avery Dennison is dedicated to providing support for PCMate Platinum.  As a customer, 
you can expect reliable products and quality service. 
 
 

Avery Dennison Technical Support 
1-800-543-6650 x3 

ris.servicetech@averydennison.com 
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A B O U T  L A B E L  D E S I G N S  
Each label design has file properties that define the layout, printer settings, supply 
information, barcode verif ier options, and security requirements for the design.  
Depending on the target printer you select for the label design, some file properties may 
or may not be active. 
In this chapter, you can learn about the file properties for label designs, including: 
♦ layout properties 
♦ printer properties 
♦ supply properties  
♦ barcode verif ier properties 
For information about RFID properties and other security options for label designs, 
contact Avery Dennison Technical Support. 

A b o u t  L a y o u t  P r o p e r t i e s  
When you create a label 
design, you must select a 
target printer and specify the 
label size.  Once you create a 
label design, you should not 
change the target printer 
because variances in printer 
settings and capabilities 
almost always impact the 
placement and appearance of 
objects on your labels. 
Using the layout properties, 
you can  
♦ create a non-printing tag 

stock background to help 
you place objects in the 
proper position and 
provide a way for printer 
operators to view and 
verify the stock before 
sending a print job to the 
printer.   

♦ create a no-print zone to 
accommodate for pressure 
sensitive label liners. 

♦ create a no-print zone to 
accommodate for margins 
on laser sheets. 

♦ make all objects that you 
add or have already added 
to the label capable of 
being a macro key and/or 
target. 

♦ make the label design compatible with design distribution and serialization services on 
the Avery Dennison Web Services Portal. 
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♦ add instructions or comments for the printer operator that appear on the Job Manager 
any time a print job is created that uses the label design. 

♦ enable security features for the label design. 
The table below provides a description of the layout properties for a label design. 
 
Properties Description 

Tag Background 
♦  Top Image 
♦  Bottom Image 
♦  Tag Background 

Set 

If you are designing for a label that has a pre-printed tag stock 
background, we recommend you create a non-printing tag stock 
background in PCMate so you can place your objects in the proper 
posit ion on the label and provide a way for printer operators to verify 
the stock before printing.  For more information, see “Creating No-Print 
Tag Stock Backgrounds” in Chapter 3. 

Printer Model You must select the printer model for the target printer on which this 
label is going to be printed.  
Different printers use different resolutions.  To ensure your label design 
is drawn to scale, select your printer for the proper resolution (DPI).  
Note: We do not recommend changing the printer model in the middle 

of or after you have created a label design.  Variances in printer 
sett ings and capabilit ies almost always impact the placement and 
appearance of objects on your labels.  If your company is using 
multiple printer families and you are not sure which printer is 
going to be used to print the labels, we recommend you create a 
label design for each possible printer. 

Design Type This f ield is not used and should always be set to Windows Design . 

Design Number This f ield is not used. 

Library This f ield is not used. 

Mark all Fields as 
Macro Key/Target 

If you are using macro lookups to input variable data and you want to 
make all objects on the label capable of being a key or target, select 
this checkbox.  If you are not using macro lookups or if you only want 
specif ic objects on the label capable of being a key or target, clear this 
checkbox.  
Note: The macro lookup feature is rarely used.  The preferred method 

is an ODBC lookup. 

Tag Size 
♦  Width 
♦  Length 
♦  Inches/Mill imeters 

You must specify the size of a single label even if the intended supply 
has multiple labels across the roll or sheet and/or multiple labels down 
a sheet.  
The Width  is the one-up width of the single label across the supply roll 
or across the short dimension of an 8 ½  x 11 sheet.  The Length  is the 
length of the label as it is fed through the printer, or down the long 
dimension of an 8 ½ x 11 sheet.  The unit of measurement displays on 
the ruler in PCMate and can be set to either Inches  (English) or 
Millimeters (metric). 
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Properties Description 

Image Start 
♦  Width 
♦  Length 
♦  Apply to 

background 
 

If you are creating a label design for pressure sensit ive labels, you 
need to establish a no-print zone for the l iner on the label. The Width  is 
the width of the l iner from the edge of the liner to the edge of the label 
(print zone).  The Length is the length of the l iner from the edge of the 
l iner to the edge of the label (print zone).  
If you are designing for a label that has a pre-printed tag stock 
background and you create a background image of the label with no 
print liner, select the Apply to background checkbox to show the tag 
stock background image in PCMate.  Also, be sure to use the correct 
Image Start dimensions.   
If you are designing for a label that has a pre-printed tag stock 
background and you create a background image of just the label, clear 
the Apply to background checkbox so that the image appears within 
the label (print zone), which is set by the Image Start  dimensions. 

Page Start 
♦  Width 
♦  Length 

If you are creating a label design for a laser printer, you need to 
establish a no-print zone for sheet on which the labels are printed.  The 
Width is the width of the no-print zone from the left edge of the laser 
sheet to the edge of the label.  The Length is the length of the no-print 
zone from the top edge of the laser sheet to edge of the label.  

Design Group If you are using the Avery Dennison Web Services portal to manage 
your label designs and/or provide serialization, you must enter the 
design group name assigned to your target retailer or brand owner.  
Otherwise, you cannot upload and/or serialize the label design. 

Notes If you want to add a comment or instructions for printer operators, you 
can add a message to the label design.  The message appears in the 
Print Module just under the label preview at the bottom of the Job 
Manager. 

Secure Design  If you want to enable security for label design serialization, select the 
Secure Design  checkbox.  If you want to disable security for the label 
design, clear the Secure Design  checkbox.  
For information about this feature, contact Avery Dennison Technical 
Support. 

Block Creating New 
Print Files 

If you want to restrict the label design to work only with print jobs 
created by the Auto-Import Routine, select the Block Creating New 
Print Files checkbox.  If you want the label design to work with all 
types of print jobs, clear the Block Creating New Print Files checkbox.  
Note: When you clear the Block Creating New Print Files checkbox, 

printer operators can add new batches to print jobs that are 
associated with the label design. 

 

About Label Designs   2-3   



A b o u t  P r i n t e r  P r o p e r t i e s  
For each label design, you 
must configure the printer 
properties.  Depending on 
the printer for which you are 
creating the label design, 
some properties may not be 
active.  
With the printer properties, 
you can 
♦ adjust the printer speed to 

accommodate for 
variances in supply. 

♦ include a batch separator 
to help printer operators 
visually recognize where 
batches end and begin 
during printing. 

♦ specify a sense type and 
position to help the printer 
locate the start position 
for new tags or labels that 
have a mark or hole.   

♦ specify whether the label 
design is for a single label 
or for multiple labels 
across and down the web 
of the supply. 

 
 
 
 
The table below provides a description of the printer setup properties. 
 
Properties Printer 

Type 
Description 

Print Speed Thermal 
 

You must select the print speed based on the supply you 
plan to use when printing labels.  Print speed affects ink 
quality on supply.  If you are printing labels on a fabric 
stock, you may want to decelerate the speed of your 
printer for better ink quality.  

Flagging Indicator Thermal  
 

You can include a batch separator for your label design.  
A batch separator is a label that is designed to help 
printer operators visually recognize where batches end 
and begin during printing.   
You can configure the batch separator to be either a 
separate label that has specif ic f lagging information, or a 
regular label that has variable data from the print job but 
is visibly longer than all other labels that print.   
For more information about batch separators, see 
Chapter 3, “Working with Label Designs.” 
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Properties Printer 
Type 

Description 

Sense Type Thermal  
 

If the supply you plan to use when printing labels has a 
mark or hole, you must specify a sense type (reflective, 
contrast, hole, hole/l iner, center aperture, etc.) that 
helps the printer locate the start posit ion for new tags or 
labels.  In addit ion, you must add a sense mark position 
(Sense to Cut) that specif ies the offset between the 
sense mark and the actual cut.   
For example, if  you want the sense mark to be a hole in 
the center of a label, you would specify the Sense Type 
to be Hole, and you would set a sense mark position that 
is half the size of the label.  Even though you can add a 
sense mark posit ion to your labels designs, you may 
need to adjust printer your sett ings.  
If you are creating a label design for stock that does not 
have a mark or hole, select None. 

Cut Type Thermal You must specify whether you want the printer to cut the 
supply and, if so, whether the cut should be made after 
each label prints or after each batch in the print job is 
printed. 

SKU Change Type Laser If you are creating a label design for a laser printer, you 
must specify where the printer should start printing after 
completing labels for the previous batch.  You can start 
the f irst label of the next batch at the very next label, the 
next row or the next sheet as follows: 
♦  Next Label – Select this option if you want the printer 

to start printing the next batch on the next label of the 
same sheet (no wasted labels). 

♦  Next Row – Select this option if you want the printer 
to start printing the next batch on the next row of 
labels on the same sheet. 

♦  Next Page – Select this option if you want the printer 
to start printing the next batch f irst label of the next 
sheet. 

♦  Next Page-Fil l Page – Select this option if you want 
the printer to start printing the next batch f irst label of 
the next sheet, and you want to f i l l the page where the 
quantity of the batch leaves empty labels. 

Centerline Thermal If you want PCMate to adjust the printed image 10 
mill imeters toward the outer edge of the printer, select 
this checkbox. 

Backfeed Thermal If you are printing carton labels and are using a printer 
that prints one label at a t ime (requir ing you to remove 
each printed label before printing the next label), you can 
enable this option so that the printer performs a back 
feed and prints on the next label correctly each time after 
you remove a printed label. 

Ink Saver Thermal If you want PCMate to calculate the minimum print area 
necessary to print the label, select this checkbox.  This 
can help minimize ink waste. 

Inverse Print Thermal If you want the printer to print the label inversely (for 
example, white-on-black), select this checkbox. 
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Properties Printer 
Type 

Description 

Reverse Print Thermal If you want the printer to print a negative image (reverse 
the printing of all objects on the label), select this 
checkbox. 

Mirror Print Thermal 
 

If you want to print clear labels for the purposes of heat 
sealing the labels on your items, select this checkbox to 
print a mirror image of the objects on the label.  If you 
want to print labels to attach to your items, clear this 
checkbox to print the objects as you see it in PCMate, 

Stop Between 
Batches 

Laser 
Thermal 

If you are creating a label design and want the printer to 
stop printing between batches, select this checkbox.   
If you want to printer to print all batches continuously, 
clear this checkbox. 

2-up Sheet Laser If you are creating a label design for a Xerox D700 laser 
printer and plan to print labels on a 14 x 11 sheet, select 
this checkbox.  PCMate creates the label design as two 
sheets of labels (not one big sheet) for printing on an 11 
x 17 sheet using a mid-page gap that is 2 t imes the page 
start width dimension.  For information about how to 
configure the page start width, see “About Layout 
Properties” in this chapter.  If you plan to print labels on 
an 8 ½ x 11 sheet, clear this checkbox. 
Note: If this checkbox is inactive, you may need to 

enable the Enable 2-up Sheet Mode advanced 
software setting.  For information about how to 
configure advanced software sett ings, refer to 
PCMate Label Printing Guide.  

Sense To Cut Thermal If you selected a Sense Type, you must add the sense 
mark posit ion that specif ies the offset between the sense 
mark and the actual cut. 

X Up Laser 
Thermal 

If you are creating a label design for a stock where 
multiple labels can be duplicated across the width of the 
supply, you must specify the total number labels that can 
be duplicated across the width of the supply.  
For example: 

  

X Up = 2 X Up = 3 
 

Cut Count Thermal Use this sett ing to take advantage of PCMate’s Sheet 
Mode and Continuous Mode finishing options. 
If you are creating a label design for a pressure sensit ive 
supply roll, you can print continuous labels on the roll, or 
you can specify for PCMate to cut the roll after a specif ic 
number of labels print.  If you want PCMate to print 
continuous labels on the roll, set the Cut Count to 0.  If 
you want PCMate to cut the roll, set the Cut Count to the 
number of labels you want to print before the count.  The 
default setting is 1.  By default, PCMate cuts the roll 
after each label (or row of labels if the X Up is greater 
than one) prints. 

Strobe Value  Thermal This f ield is not used. 
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Properties Printer 
Type 

Description 

Rows Per Page Laser If you are creating a label design for a laser printer, you 
must specify the number of rows of labels that can be 
printed on a single sheet. 

 
 

 

14 5 10 
 

DPI Laser If you are creating a label design for a laser printer, you 
can decrease the dpi to minimize ink use. 
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A b o u t  S u p p l y  P r o p e r t i e s  
If you are creating a label 
design for a thermal printer, 
you must configure the supply 
properties.   
If you are creating a label 
design for an ink jet or laser 
printer, you do not have to 
configure the supply 
properties. 
Supply properties include the 
stock and the ink colors for 
each print head/station.  The 
combination of the stock and 
ink determines the amount of 
energy the printer uses to 
print the labels.  The more 
accurate the information, the 
better print quality of your 
labels. 
As you are creating your label 
design, PCMate displays 
objects on the screen using 
the same colors you select 
for the print stations.    
 
 
 
 
 
 
 
The table below provides a description of the supply properties for a label design. 
 
Properties Description 

Fabric / Stock Select the material that should be used for the supply.  Available 
options differ for each printer model. 

Ink  
♦  Station 1 
♦  Station 2 
♦  Station 3 

Select the type and color of ink in each print head/station as follows: 
♦  Station 1 – Select the type and color of ink that should be used on 

the back of the label. 
♦  Station 2 – Select the type and color of ink that should be used on 

the front of the label.  All single-head printers use this print 
station. 

♦  Station 3 – If the target printer has three print heads, select the 
second type and color of ink that should be used on the front of 
the label. 

Stock ID This f ield is not used. 
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A b o u t  B a r c o d e  V e r i f i e r  P r o p e r t i e s  
If you are creating a label 
design for a 6x6 or SNAP 
thermal printer that is 
equipped with a 
scanner/verif ier option, you 
can enable bar code 
verif ication for the label 
design. 
If you are creating a label 
design for any other type of 
printer, this feature is not 
available. 
Barcode verif ier properties 
not only enable the 
scanner/verif ier on your 
printer, but also include 
options that you can 
configure for determining 
whether the bar code print 
quality is at an acceptable 
level. 
Before configuring barcode 
verif ier properties, you 
should the add barcode 
objects to your label design.  
Otherwise, the barcode types 
under Symbologies to be 
excluded may not be active. 
 
 
 
 
The table below provides a description of the barcode verif ier properties for a label 
design. 
 
Field/Set Description 

Enable Verif ier Scanning Select this checkbox to enable the scanner/verif ier on 
your printer. 

Verif ier Type Select the type of barcode verif ication option you have 
on your printer (SV-100 or VL-70). 
Note: The VL-70 is discontinued. 

Symbologies to be excluded  
♦  UPC-A / UPC-E / EAN-8 / EAN-13 

(All EAN type bar codes) 
♦  Code 39 
♦  Code 128 and EDI Code 128 
♦  Interleave 2 OF 5 
♦  Code 93 

This feature is no longer available for either barcode 
verif ication option. 
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Field/Set Description 

Reasons For Failure 
♦  Out Of Specif ication Warnings 
♦  Out Of Specif ication Rejections 
♦  ANSI Decodabil ity Grade Test 
 

The scanner/verif ier in your printer uses a grading 
function to assure that bar code print quality is at an 
acceptable level.  
If a readabil ity issue is detected, the scanner/verif ier 
issues a “barcode out of specif ication” warning or 
rejection code based on the severity of the issue.  
Select the checkboxes based on the criteria you want 
the scanner/verif ier to use when scanning barcodes: 
♦  Out Of Specif ication Warnings – This feature is only 

available for the discontinued VL-70 barcode 
verif ication option.  If enabled, “barcode out of 
specif ication” warnings cause the barcode scan to 
fail and the printer either halts or reprints the label 
before continuing printing; if  disabled, the barcode 
scan passes even if a “barcode out of specif ication” 
warning occurs. 

♦  Out Of Specif ication Rejections – This feature is only 
available for the discontinued VL-70 barcode 
verif ication option.  If enabled, “barcode out of 
specif ication” rejections cause the barcode scan to 
fail.  If  disabled, the barcode scan passes even if a 
“barcode out of specif ication” rejection occurs. 

♦  ANSI Decodabil ity Grade Test – If enabled, you can 
select a Pass on Grade (A – D) to determine the 
minimum grade required for the barcode scan to 
pass. 

Number of Failures Before Halt 
♦  Consecutive Failures 
♦  Accumulative Failures 

♦  Consecutive Failures – If enabled, you can set the 
number of consecutive failures that can occur before 
the printer is halted.  

♦  Accumulative Failures – This feature is only available 
for the discontinued VL-70 barcode verif ication 
option. 

Number of Scans to Pass Set the minimum number of scans the scanner/verif ier 
must make to inspect the barcode.  The recommended 
and minimum setting for this option is 2. 

 
 

2-10  Label Design Guide   



W O R K I N G  W I T H  L A B E L  D E S I G N S  
A label design is a template that PCMate merges with a variable data file to create a 
print job.  PCMate organizes label designs in design sets.  A design set is a group of 
similar label designs.  You can name your design sets and label designs according to how 
you want to organize your work, for example, by author, by printer family, by project, and 
so on.  
In this chapter, you can learn about print stations, as well as how to 
♦ create label designs. 
♦ edit f ile properties for label designs. 
♦ delete label designs. 
♦ copy label designs to another design set. 
♦ move label designs to a different design set. 
♦ export label designs. 
♦ import label designs.  
♦ create batch separators for label designs. 
♦ edit batch separators for label designs. 
♦ remove batch separators for label designs. 
♦ create no-print tag stock backgrounds. 
♦ create no-print zones. 

A b o u t  P r i n t  S t a t i o n s  
For each label design, you must select a target printer.  A printer must have at least one 
print head, and can have up to three print heads.  A print head can be on the top or the 
bottom.  Some printers have two print heads on top, while other printers have one print 
head on top and one print head on the bottom.  There are many types of configurations. 
In PCMate, each print head represents a print station, and each print station represents a 
part of the label design.  As you work with each label design, you must keep track of 
which part you are editing.  The following figure illustrates all possible parts of a label 
design that you can view and/or edit. 

 
  

3  
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The table below provides a description of how the print stations in PCMate correspond 
with the label design and the print head(s) on a printer. 
 
Print Station Print Output Description 

Top (Station 2) Label  For printers with one top print head, this is the front 
side of the label.  For printers with two top print 
heads, this is the front left print station for a SNAP 
500 printer, or the front right side print station for a 
676 printer. 

Top (Station 3) Label For printers with two top print heads, this is the front 
left print station for a SNAP 500 printer, or the front 
right print station for the 676 printer. 

Top (Station 2 & 3) Label For printers with two top print heads, this is the front 
side of the label, representing both top print heads. 

Bottom (Station 1) Label This is always the back side of the label. 

Flag Top (Station 2) Batch 
Separator 

For printers with one top print head, this is the front 
side of the batch separator for the label design.  For 
printers with two top print heads, this is the front left 
print station for a SNAP 500 printer, or the front r ight 
side print station for a 676 printer. 

Flag Top (Station 3) Batch 
Separator 

For printers with two top print heads, this is the front 
left print station for a SNAP 500 printer, or the front 
right print station for the 676 printer. 

Flag Bottom (Station 1) Batch 
Separator 

This is always the back side of the batch separator 
for the label design. 

 
As an example, the following figure illustrates a printer with two print heads – one on top 
and one on bottom.  These include the 6x6 and SNAP printer families. 

Label Batch Separator 
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Some printers have two print heads, but both print heads are on top.  In this case, the 
print stations would be Top (Station 2) and Top (Station 3) as shown in the figure below.  
The following figure illustrates a printer with three print stations.  These include the 6x6 
and SNAP printer families.  For all SNAP printer models, the positions of the top print 
stations are reversed.  Top (Station 3) prints f irst and would appear in the image on the 
left.  Top (Station 2) prints second and would appear in the image on the right. 

Label Batch Separator 

  

When creating label designs, it is important to understand the orientation of each label 
design with regards to the feed direction for the target printer.  For example, the print 
head for Top (Station 2) prints on the inside of the roll on a 640x printer, versus on a 
SNAP printer where the print head for Top (Station 2) prints on the outside of the roll.  

640x, 98xx, and 61x Printers 6x6 and SNAP Printers 

  

PCMate has a ruler to help with orientation and design of your labels with regards to the 
feed direction for the target printer. 

    

The arrow that appears with the Length indicates the feed direction.  If you click , you 
can change the ruler and all other metrics from inches to centimeters.  
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C r e a t i n g  L a b e l s  D e s i g n s   
Before you create a label design, you must know the following information:   
♦ target printer model  
♦ supply orientation (how the labels feed into the printer) 
In addition, you may want to consider the following depending on the features you plan to 
use:  
♦ Place all pre-printed background images (.JPG files) in the following default working 

folder: 
C:\Paxarwin\Tagstock 

♦ Place all picture/logo images (.BMP, .PCX, and .JPG files) you plan to add to the label 
design in the following default working folder: 
C:\Paxarwin\Logos 

♦ Install Windows fonts, if needed, for the label design using a standard Windows font 
installation (Control Panel>Fonts). 

You can create and save any number of label designs.  Each label design has multiple 
files associated with it.  Therefore, when you create a label design, PCMate automatically 
creates a working folder in the following default location:  
C:\Paxarwin\formats\[DESIGN SET NAME]\[LABEL DESIGN NAME] 

If you copy, move, or export a label design, PCMate handles all of the files in the label 
design’s working folder accordingly.   
The table below provides a description of the minimum files PCMate creates for each 
label design in its working folder.  
 
File Description 

[LABEL DESIGN NAME].DTD This f i le holds temporary f i les associated with the label 
design.  If you ever delete this f i le, PCMate automatically 
recreates the f i le upon opening the label design. 

[LABEL DESIGN NAME].VER This f i le tracks the version number for the label design.  If 
you open and try to save a label design, PCMate checks the 
version number and issues warning if the label design is 
currently open by another user or has been recently 
changed by another user. 

[LABEL DESIGN NAME].XLD This f i le holds all of the f ile properties and object properties 
for the label design. 

 
Exporting a label design also collects and moves any tag backgrounds, logo set images, 
and auto-import maps.  Therefore, do no try to move manually f iles into folders.  Always 
use the export function.  For information about how to export a label design, see 
“Exporting Label Designs” later in this chapter. 
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To Create a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. On the File menu, click New. 
4. When prompted to select a printer, click the model of the target printer on which the 

label is going to be printed and then click OK. 
Note:  We do not recommend changing the printer model in the middle of or after you 

have created a label design because variances in printer settings and 
capabilities almost always impact the placement and appearance of objects on 
your labels.  If your company is running multiple printer families and you are 
not sure which printer is going to be used to print the labels, we recommend 
you create a label design for each possible printer.   

5. In the Design Properties dialog box, configure the file properties for the label design 
and then click OK. 
Note:  Depending on the printer model you select, some label properties and object 

properties may not be active.  For example, the Cut Type on the Printer Setup 
tab is only active for 98xx printers.  If an option is inactive (grayed out), it 
means the option is not supported for the printer model you selected.  For a 
description of f ile properties for label designs, see Chapter 2, “About Label 
Designs.” 

6. Add objects to the label design as needed.  For more information, see Chapter 6, 
“Adding Objects.” 
Note:  Depending on the target printer you select, a label design can have multiple 

sides based on the number of print stations/heads.  Before you start adding 
objects to the label design, be sure to select the correct side on which you are 
your objects to reside. 
If you intend to export the label design for use with a previous version of 
PCMate, take care not to use any advanced features that may not be 
supported.  An example is extended Unicode characters, which are only 
supported in version 6.0 and 7.0 and would be lost exporting to version 4.0. 

7. On the File menu, click Save. 
8. From the Design Set list box, select an existing design set in which you want to save 

the label design, or enter the name for a new design set. 
Note:  If you enter the name for a new design set, PCMate creates a new working 

folder in the following default location: 
C: Paxarwin\formats\[DESIGN SET NAME] 

9. In the Design text box, enter the file name for the label design or select a file name 
from the list to overwrite an existing label design. 
Note:  Within a design set, the file name for each label design must be unique.  

However, you can have duplicate file names in different design sets. 
10. Click OK. 
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E d i t i n g  F i l e  P r o p e r t i e s  f o r  L a b e l s  D e s i g n   
Once you create a label design, you can save and then edit the file properties as needed.  
However, we do not recommend changing the printer model in the middle of or after you 
have created a label design because variances in printer settings and capabilities almost 
always impact the placement and appearance of objects on your labels.  If your company 
is using multiple printer families and you are not sure which printer is going to be used to 
print the labels, we recommend you create a label design for each possible printer.   

To Edit File Properties for a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. On the File menu, click Open. 
4. In the Design Set frame, navigate to the folder in which label designs for the design 

set reside. 
5. In the Design frame, select the label design you want to edit. 
6. Click OK. 
7. If PCMate prompts you for a design password, enter the password and then click OK. 

Note:  Many label designs are password protected.  
8. On the File menu, click Properties. 
9. Edit the file properties as needed. 

Note:  We do not recommend changing the printer model in the middle of or after you 
have created a label design because variances in printer settings and 
capabilities almost always impact the placement and appearance of objects on 
your labels.  If your company is using multiple printer families and you are not 
sure which printer is going to be used to print the labels, we recommend you 
create a label design for each possible printer.   

10. On the File menu, click Save. 
11. On the File menu, click Close. 

D e l e t i n g  L a b e l  D e s i g n s   
At any time after you create a label design, you can delete the label design.  When you 
delete a label design, PCMate permanently removes the working folder for the label 
design, along with all associated files for the label design.  If you delete the only label 
design in a design set, PCMate deletes the working folder for the design set as well.   

To Delete a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. On the Tools menu, click Design File Manager. 
4. From the From Design Set list box, select the design set to which the label design 

you want to delete belongs. 
5. In the Design l ist, click the label design you want to delete. 
6. Click Delete Selected Design. 

Note:  If you delete the only label design in a design set, PCMate deletes the design 
set as well.   

7. Click Close. 
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C o p y i n g  L a b e l  D e s i g n s  t o  a n o t h e r  D e s i g n  S e t  
PCMate organizes label designs in design sets.  If needed, you can copy a label design to 
another design set.  When you copy a label design, PCMate copies the working folder for 
the label design, along with all associated files for the label design, to the design set you 
select. 

To Copy a Label Design to another Design Set 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. On the Tools menu, click Design File Manager. 
4. From the From Design Set list box, select the design set to which the label design 

you want to copy belongs.  Then, in the Design list, click the label design you want to 
copy. 

5. From the To Design Set list box, select the design set to which you want to copy the 
label design. 

6. Click Copy. 
Note:  If there is already a label design with the same name, PCMate prompts you to 

overwrite the existing design.   
7. Click Close. 

M o v i n g  L a b e l  D e s i g n s  t o  a  D i f f e r e n t  D e s i g n  S e t  
PCMate organizes label designs in design sets.  If needed, you can move a label design 
to another design set.  When you move a label design, PCMate moves the working folder 
for the label design, along with all associated files for the label design, to the design set 
you select. 

To Move a Label Design to Different Design Set 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. On the Tools menu, click Design File Manager. 
4. From the From Design Set list box, select the design set to which the label design 

you want to move belongs.  Then, in the Design l ist, click the label design you want to 
move. 

5. From the To Design Set list box, select the design set to which you want to move the 
label design. 

6. Click Move. 
Note:  If there is already a label design with the same name, PCMate prompts you to 

overwrite the existing design. 
7. Click Close. 
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E x p o r t i n g  L a b e l  D e s i g n s  
You can export one or more label designs to a .ZIP file that can be imported at another 
PCMate workstation.  With the exception of fonts and variable named logo files, the .ZIP 
file contains all of the files associated with each label design you export.  You can save 
the .ZIP file in a specified directory location and you can extract the contents of the .ZIP 
file in a specified directory location. 
PCMate is an upward compatible system.  Newer versions of PCMate retain features and 
functions from previous versions, so the philosophy is to always move to the latest 
version for compatibility and to obtain the complete feature set.  When exporting label 
designs, be aware that advanced features may not be supported in previous versions.  

To Export a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. On the File menu, click Export and then click Windows Design. 

Note:  The PCL and Pathfinder exports are no longer supported. 
4. Next to the Path text box, click Browse. 
5. Navigate to the directory location where you want to save the .ZIP file.  

Note:  If you want to use the label design with the Auto-Import Routine, you must 
export the label design to the location where PCMate looks for import maps 
and label designs.  For more information about the Auto-Import Routine, see 
Chapter 7, “Working with the Auto-Import Routine.” 

6. In the File name text box, enter the name you want to give the .ZIP file. 
7. Click Save. 
8. In the Design Set l ist, click the design set to which the label design you want to 

export belongs. 
9. In the Design l ist, click the label design you want to export. 

Note:   If you want to export all of the label designs that belong to the design set, 
click Select All. 

10. Repeat steps 8–9 for each label design you want to export to the .ZIP file. 
11. If you are exporting for PCMate 4.0 or earlier version, select the Export to Non-

Unicode Format checkbox.  Otherwise, skip this step. 
12. Click OK. 

Note:  The export function does not include fonts or variable named logo files in the 
.ZIP file.  You must manually move fonts and variable named log files. 

I m p o r t i n g  L a b e l  D e s i g n s  
You can import one or more label designs that have been exported to a .ZIP file.  When 
import label designs from a .ZIP file, PCMate creates a folder in the following default 
location:  
C:\Paxarwin\formats\[DESIGN SET NAME]\[LABEL DESIGN NAME] 

To Import a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. On the File menu, click Import and then click Windows Design.  

Note:  The DOS PCMate and PCL imports are no longer supported. 
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4. Next to the Path text box, click Browse. 
5. Navigate to the directory location where the .ZIP file resides.  
6. Click the .ZIP file and then click Open. 
7. In the Design Set l ist, click the design set to which the label design you want to 

import belongs. 
8. In the Design l ist, click the label design you want to import. 

Note:  If you want to import all of the label designs in the design set, click Select All. 
9. Click OK. 

C r e a t i n g  B a t c h  S e p a r a t o r s  f o r  L a b e l  D e s i g n s  
A batch separator is a label that is designed to help printer operators visually recognize 
where batches end and begin during printing.  For each label design, you can create a 
batch separator.  You can configure the batch separator to be either a separate label that 
has specific f lagging information, or a regular label that has variable data from the print 
job but is visibly longer than all other labels that print.  
Batch separators work differently depending on whether your label design includes a 
sense mark.  Non-sense mark stock, you can use any batch separator.  The table below 
provides a description of the different types of batch separators you can configure for 
your label designs. 
 
Batch Separator Description 

Small, Medium, Large, 
X-Large 

If you select one of these batch separators, PCMate creates a new 
label that is longer than the other labels in each batch and allows 
you to add specif ic f lagging information, such as the Design Name, 
Format Revision,  Batch File Name, and Quantity.   Depending on 
which batch separator you select, you can increase the length of the 
batch separator by 1/16th of an inch to 3/8th of an inch. 
For label designs that have a sense mark, this batch separator 
requires the use of two labels – the batch separator that may include 
specif ic f lagging information and is longer than all other labels in the 
batch, and a blank label that is shorter than all other labels in the 
batch. 

Tag Flags For a label design that does not use a sense mark, selecting this 
batch separator makes the last label in each batch longer than all 
other labels.  For a label design that uses a sense mark, selecting 
this batch separator uses the last two labels in each batch – making 
one label longer than the other labels in the batch, and the other 
label shorter than the other labels in the batch.  
This batch separator does not create a new label.  Therefore, you 
cannot add specif ic f lagging information if you select this type of 
batch separator. 

Zero Length Flag Selecting this batch separator creates a new label that is the same 
length as all other labels in the batch and can have specif ic f lagging 
information.  Because the batch separator is the same length as all 
other labels in the batch, it may be hard to identify.  

 
If you select a batch separator that creates a new label, you can add specific f lagging 
information.  We recommend you add a function field for the SKU NUMBER so that when 
a batch separator prints, the printer operator can see which batch out of how many 
batches has printed.  For example, 1 of 65, 2 of 65, 3 of 65, and so on. 
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In addition, we recommend you add four data fields, to include: 
♦ DESIGN NAME 
♦ FORMAT REVISION 
♦ BATCH FILE NAME 
♦ QUANTITY. 

To Create the Batch Separator for a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Either create or open a label design. 
4. On the File menu, click Properties. 
5. In the Design Properties dialog box, click the Printer Setup tab. 
6. From the Flagging Indicator list box, select the appearance you want to apply to the 

batch separator. 
Note:  This list box determines whether the label design uses a batch separator to 

help printer operators visually recognize where batches end and begin during 
printing.  If set to None, PCMate does not print batch separators even if you 
place objects on the different sides of the batch separator.  

7. Click OK. 
8. On the View menu, click Side and then click the side of the batch separator you want 

to edit. 
Note:  PCMate identif ies the sides of a batch separator with a “Flag” prefix.  Flag 

Bottom (Station 1) is always the back side of the batch separator.  For 
printers with one top print head, Flag Top Left (Station 2) is the front side of 
the batch separator.  For printers with two top print heads, Flag Top Right 
(Station 3) is the front left print station for a SNAP 500 printer, or the front 
right print station for the 676 printer.  

9. Edit the side of the batch separator as needed. 
10. Repeat steps 8–9 for each side. 
11. On the File menu, click Save. 
12. On the File menu, click Close. 
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E d i t i n g  B a t c h  S e p a r a t o r s  f o r  L a b e l  D e s i g n s  
At any time after you create the batch separator for a label design, you can edit the batch 
separator as you see fit. 

To Edit the Batch Separator for a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open the label design for that has the batch separator you want to edit. 
4. On the View menu, click Side and then click the side of the batch separator you want 

to edit. 
Note:  PCMate identif ies the sides of a batch separator with a “Flag” prefix.  Flag 

Bottom (Station 1) is always the back side of the batch separator.  For 
printers with one top print head, Flag Top Left (Station 2) is the front side of 
the batch separator.  For printers with two top print heads, Flag Top Right 
(Station 3) is the front left print station for a SNAP 500 printer, or the front 
right print station for the 676 printer. 

5. Edit the batch separator as you see fit. 
6. On the File menu, click Save. 
7. On the File menu, click Close. 

R e m o v i n g  B a t c h  S e p a r a t o r s  f r o m  L a b e l  D e s i g n s  
If you create the batch separator for a label design and decide you no longer want to use 
it, you can remove the batch separator without having to remove any objects you may 
have added to one or more of the sides.  

To Remove the Batch Separator from a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open the label design that has the batch separator you want to remove. 
4. On the File menu, click Properties. 
5. In the Design Properties dialog box, click the Printer Setup tab. 
6. From the Flagging Indicator list box, select None.  
7. Click OK. 
8. On the File menu, click Save. 
9. On the File menu, click Close. 
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C r e a t i n g  N o - P r i n t  T a g  S t o c k  B a c k g r o u n d s  
If there is a background image on your tag stock, we recommend you create a non-
printing tag stock background in PCMate so you can place your objects in the proper 
position on the label and provide a way for printer operators to verify the stock before 
printing.  You can create two types of non-printing tag stock backgrounds to represent a 
more accurate view of the front and back of a label in PCMate, including: 
♦ A static tag stock background 
♦ A dynamic tag stock background 
If all of your labels have the same tag stock background, you should create a static tag 
stock background.  However, if different labels have different tag stock backgrounds, for 
example, the background changes for each size, then you should create a dynamic tag 
stock background. 
Before you can create a non-printing tag stock background, you must put background 
images (.JPG or .BMP files) in the following default working folder:  
C:\Paxarwin\Tagstock 

Because PCMate force fits the image to the design dimensions, image files must be a one 
up image of the artwork and the exact same size as the tag stock.  If you are using 
pressure sensitive labels and require a liner around the edge of the label, you can either 
add the liner to image file or configure PCMate to display the image file within a liner you 
create.  We recommend you configure PCMate to display the tag stock background image 
file within a liner you create.  For information about how to create a liner, see Chapter 3, 
“Working with Label Designs.” 
If you are creating a dynamic tag stock background, you must use the following naming 
conventions for your image files: 
[BACKGROUND NAME]_[VARIABLE DATA].JPG 

The [BACKGROUND NAME] can be any name you want to give the set of images for 
identif ication.  The [VARIABLE DATA] must be the value of the object after PCMate 
mergers the label design with a variable data file.  

To Create a Static No-Print Tag Stock Background 
1. Place the image files in the default working folder. 
2. Open PCMate, and log on if required. 
3. On the Window menu, click Design Module. 
4. Either create or open a label design. 
5. On the View menu, click the side of the label or batch separator for which you want to 

create a static no-print background. 
Note:  For information about print stations, see “About Print Stations” earlier in this 

chapter. 
6. On the File menu, click Properties. 
7. From the Top Image l ist box on the Tag Layout tab, select the tag stock background 

image file you want to display on the front of the label. 
8. From the Bottom Image list box, select the tag stock background image file you want 

to display on the back of the label. 
9. Click OK. 
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To Create a Dynamic No-Print Tag Stock Background 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Either create or open a label design. 
4. Place the image files in the default working folder. 

Note:  If you already have a label design open, on the File menu, click Properties.  
5. On the File menu, click Properties. 
6. Select the Tag Background Set checkbox. 
7. From the Top Image l ist box on the Tag Layout tab, select the name of the 

background images you want to dynamically display on the front of the label. 
8. From the Bottom Image list box on the Tag Layout tab, select the name of the 

background images you want to dynamically display on the back of the label. 
9. Click OK. 
10. Add the object in which a change in variable data should prompt PCMate to 

dynamically change the preview for the tag stock background. 
Note:  If you have already added the object, click the object.  (On the Edit menu, click 

Select Fields.)  On the Edit menu, click Properties. 
11. On the Field Tag tab, select the Tag Background Key Field checkbox. 

Note:  PCMate knows to change the preview of the tag stock background by reading 
the image file names you place in the default working folder.  The [VARIABLE 
DATA] value that you specify in the file name tells PCMate to switch to that 
image file. 

12. Click OK. 
13. Repeat steps 9–11 for each object in a change in variable data should prompt PCMate 

to dynamically change the preview for the tag stock background. 
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C r e a t i n g  N o - P r i n t  Z o n e s  
If you are creating a label design 
for pressure sensitive labels, you 
need to establish a no-print zone 
for the liner on the label.  If you 
are creating a label design for a 
laser printer, you need to 
establish a no-print zone for the 
sheet margins on which the labels 
are printed.  
The figure on the right illustrates 
the settings you must configure to 
create no-print zones on your 
label designs.  
 

To Create a No-Print Zone for a Pressure Sensitive Label Liners 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Either create or open a label design. 
4. On the File menu, click Properties. 
5. On the Tag Layout tab, locate the Image Start frame. 
6. In the Width text box, enter the width of the liner from the edge of the label to the 

edge of the print zone. 
7. In the Length text box, enter the length of the liner from the edge of the label to the 

edge of the print zone. 
8. If you are designing for a label that has a pre-printed tag stock background and you 

create a tag stock background to display in PCMate, select the Apply to background 
checkbox to show the tag stock background image within the liner. 
Note:  If you clear the Apply to background checkbox, the tag stock background 

image appears over the liner and PCMate may not present the label art 
correctly. 

9. Click OK. 
10. On the File menu, click Save. 
11. On the File menu, click Close. 

To Create a No-Print Zone for Margins on Laser Sheets 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Either create or open a label design. 
4. On the File menu, click Properties. 
5. On the Tag Layout tab, locate the Page Start frame. 

Note:  If the Page Start frame does not appear on the Tag Layout tab, you need to 
select a laser printer model. 

6. In the Width text box, enter the width of the no-print zone from the left edge of the 
laser sheet to the edge of the label. 
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7. In the Length text box, enter the length of the no-print zone from the top edge of the 
laser sheet to edge of the label. 

8. Click OK. 
9. On the File menu, click Save. 
10. On the File menu, click Close. 

P r i n t i n g  H a r d  C o p i e s  a n d  F o r m a t  S h e e t s  f o r  L a b e l  D e s i g n s  
A hard copy and format sheet shows the side of the label design you are currently viewing 
and includes a format sheet with all the field/object attributes that you can review.  The 
figure below illustrates a hard copy and format sheet for a label.  

 

 

You can only print a hard copy and format sheet for one label at a time.  

To Print a Hard Copy and Format Sheet for a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open the label design for which you want to print a hard copy and format sheet.  
4. On the View menu, click Side and then click the side of the label design you want to 

review.  
Note:  PCMate identif ies the sides of a batch separator with the “Flag” prefix.  Flag 

Bottom (Station 1) is always the back of the batch separator.  For a printer 
with one or two print stations, Flag Top Left (Station 2) is the front of the 
batch separator.  For a printer with three print stations, Flag Top Left (Station 
2) is the front, left side of the batch separator.  Flag Top Right (Station 3) is 
the front, right side of the label.  For more information about label sides and 
print stations, see Chapter 3, “Working with Label Designs.” 

5. On the File menu, click Hard Copy. 
6. When prompted, configure the print options and then click OK. 
7. On the File menu, click Close. 
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P r e v i e w i n g  L a b e l  D e s i g n s  
At any time, you can look at the label design to see how the label is going to look once it 
is printed (without any object borders).  

To Preview a Label Design 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open the label design you want to preview. 
4. On the File menu, click Preview Design.  
5. To return to the normal view, repeat step 4. 
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A B O U T  O B J E C T S  
Label designs can have many different types of objects.  Some objects are design 
elements, and some objects serve as placeholders for variable data.  In this chapter, you 
can learn about:  
♦ types of objects 
♦ basic properties for objects 
♦ f ield tag properties for objects 
♦ batch copy properties for objects 
♦ substring properties for objects. 

A b o u t  O b j e c t  T y p e s  
There are seven types of objects that you can add to a label design. 
 
Object Type Description 

Text Placeholder This type of object is a placeholder for alphanumeric text that 
prints on a label.  You can input data into this object either 
manually or via a macro or ODBC lookup. 

Barcode Placeholder This type of object is a placeholder for a barcode that prints 
on a label.  You can input data into this object either manually 
or via a macro or ODBC lookup.  You input variable data, and 
PCMate prints the variable data as a barcode. 

Rectangle/Line Design 
element 

This type of object is a rectangle or l ine that prints on a label.  

Care Symbol Placeholder This type of object is a placeholder for a care symbol that 
prints on a label.  You can input the numerical value for the 
care symbol into this object either manually or via a macro or 
ODBC lookup. 

Pictures Placeholder This type of object is a placeholder for an image fi le that 
prints on a label.  You must place all image fi les in the 
following default working folder: 
C:\Paxarwin\Logos 

You can save image fi les using a structured naming 
convention or a non-structured naming convention depending 
how you want variable data to be input into your print jobs.  If 
you want PCMate to import/export image fi les with other label 
design information, we recommend using a structured naming 
convention that can be saved with each label design as 
opposed to a non-structured naming convention that requires 
variable data to be input into the print job. 
Structured naming convention 
The structured naming convention must be 8 numeric 
characters.  The first three characters are not used by 
PCMate and can be alphanumeric.  The next two characters 
identify the name of the logo set.  The final three characters 
identify the name for the logo fi le in the logo set.  The last 
five characters (the name of the logo set and the name of 
the file in the logo set) must be numeric.  
Example: PIC22333.BMP or PIC22333.PCX 
This is logo fi le is 333 in logo set 22. 

4  
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Object Type Description 

  If  you are creating a label design for use with an ODBC library 
lookup, manual data entry, or auto-import, the variable data 
must match the name of the f i le in the logo set (the last three 
characters) for PCMate to identify and print the desired 
image. 
If you do not select a default image when adding a picture 
logo that uses a structured naming convention, PCMate shows 
a red frame on the label design that represents the largest 
image in the logo set and outlines the position and size of the 
object.  If you select a specif ic image from the logo set, 
PCMate displays the image as the default image on the label 
design, which can be overridden during an ODBC library 
lookup, manual data entry, or auto-import.  
Non-structured naming convention 
Only Windows limits the length logo fi le names using a non-
structured naming convention.  If you are creating a label 
design for use with an ODBC library lookup, manual data 
entry, or auto-import, the variable data must match the image 
file name (including the f ile extension) for PCMate to identify 
and print the desired image.  
If you do not select a default image when adding a picture 
logo that uses a non-structured naming convention, PCMate 
does not show a red frame or an image on the label design, 
which may make it diff icult to place other objects.  We 
recommend temporarily selecting an image that represents 
the largest image that could be input in the object so that you 
can see the posit ion and size of the object on the label 
design. 

Function Field Placeholder This type of object is a placeholder for alphanumeric text that 
prints on a label.  The text is dynamically generated by 
PCMate and cannot be modified.  There are eight types of 
function f ield objects, including:  
♦  Date – Current date of the printer clock 
♦  Quantity – Quantity f ield sent to the printer 
♦  Time – Time stamp of the printer 
♦  Euro Date – As set by the printer 
♦  SKU # – The line number when sending multiple batches to 

the printer; used on flagging for indication of 1 of 5, 2 of 5, 
3 of 5, and so on. 

♦  Fixed Text – Forced fixed data that cannot be altered by 
any autoimport or editing of saved batch data 

♦  User Security ID – As set by the combination of PCMate 
and D2Comm at the t ime of print 

♦  Batch ID – 8-digit number assigned by PCMate to each 
batch in a print job.  The number is random for non-secure 
designs and controlled by D2Comm for secure designs.  

PCMate uses User Security ID and Batch ID function f ield 
objects with Avery Dennison Web Services.  For information 
about these function f ield objects, contact Avery Dennison 
Technical Support. 

Data Field Placeholder This type of object is a placeholder for any variable data that 
does not print on a label, but may be merged with other data 
to populate an object that does print on the label. 
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A b o u t  B a s i c  P r o p e r t i e s  f o r  O b j e c t s  
In general, objects have a set of properties that define their attributes.  The table below 
provides a description of basic properties for text, rectangle/line, care symbol, picture, 
function field, and data field objects.  For information about properties for barcode 
objects, see Chapter 5, “About Barcode Objects.” 
 
Properties Applicable 

Object(s) 
Description 

Ascenders Text If the data for this object has characters that appear above 
the cap height and you want the characters to print on the 
label, select this checkbox.  If you do not want characters that 
appear above the cap height to print on the label, clear this 
checkbox.  

 
image source: www.wik ipedia.com 

Barcode Type Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects." 

Box/Line 
Dimensions 
(in) 
♦  Width Size 
♦  Length Size 

Rectangle/ 
Line 

Set the dimensions for the box or l ine based on the feed 
direction of the supply as follows: 
♦  Width Size – Set the height of the box or l ine in inches. 
♦  Length Size – Set the length of the box or l ine in inches. 

Central 
Sequencing 

Function 
Field 

For information about this guaranteed unique serialization 
feature, contact Avery Dennison Technical Support. 

Character Set Text If you select the Download Font as Graphic checkbox, this 
l ist box becomes active to display what character sets are in 
the Windows font.  This l ist box does not restr ict any of the 
available character sets for manual input or importing of data.   

Code Page ♦  Text 
♦  Data Field 

If you want this object to use a printer-resident font, you must 
select the character set allowed for data in the object.  For 
example, code page 437 uses the MS-DOS character set of 
the original IBM PC while code page 850 uses the MS-DOS 
character set mostly seen in Western Europe as follows: 

 
Code Page 437 

 
Code Page 850 

The character set you select determines which characters are 
available in PCMate’s character map.  The character sets that 
are available depends on the target printer selected for the 
label design as well as the font you select for the object.  
images source: www.wikipedia.com 
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Properties Applicable 
Object(s) 

Description 

Color ♦  Text 
♦  Barcode 
♦  Rectangle/

Line 
♦  Care 

Symbol 

If you are creating a label design for a laser printer, select the 
color for which data in this object should appear.  
For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Decenders Text If the data for this object has characters that appear below the 
baseline and you want the characters to print on the label, 
select this checkbox.  If  you do not want characters that 
appear below the baseline to print on the label, clear this 
checkbox. 

 
image source: www.wik ipedia.com 

Download 
[XXX] As 
Graphic 

♦  Text 
♦  Barcode 
♦  Picture 
 

If this object uses a PC-resident font or image and you want 
PCMate to send the font or image to the printer as a graphical 
image with your print jobs, select this checkbox.  If this object 
uses a printer-resident font or image, clear this checkbox. 
Note: If you select this checkbox, you may increase the 

amount of time it takes to print labels because the 
printer must treat the data as a bitmapped object. 
A printer-resident character set or image is saved in the 
printer’s memory module.  A PC-resident character set 
or image is not saved in the printer’s memory module.  
If an object uses a PC-resident character set or image, 
and your printer does not have this resident font or 
picture image installed, the printer uses its default 
character set for text and does not print the PC-resident 
images at all.  

♦  TEXT OBJECTS: To use Windows fonts installed on your 
PC, you must select this checkbox, as well as select the 
Windows font and other font attr ibutes.  

♦  PICTURE OBJECTS: For thermal printers, you can 
download .BMP and .PCX image fi les as a graphic.  
However, the image fi les must be two color (one bit) f i les 
only.  For laser printers, you can download color .JPG 
image fi les as a graphic. 

For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 
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Properties Applicable 
Object(s) 

Description 

Draw Method 
♦  Width 

♦  Text 
♦  Care 

Symbol 
♦  Function 

Field 

To obtain a visually pleasing result, you can select the 
manner in which you want PCMate to adjust the space 
between individual letter forms and make uniform adjustments 
of spacing within this object as follows: 
♦  Squeeze To Fit – PCMate prints data normally until i t 

reaches the width of the object at which point the character 
string or image starts to compress so that all of the data f it.  
If  you select this draw method, you must specify the width 
of the f ield in the current unit of measure ( inches or 
mill imeters). 

♦  Proportional Fit – PCMate expands the horizontal spacing 
between characters in the text string or between images so 
the data uniformly f its within the object.  If you select this 
draw method, you must specify the width of the f ield in the 
current unit of measure (inches or mill imeters). 

♦  Stretch To Fit – PCMate expands the horizontal spacing 
between characters in the text string or between images so 
the data uti l izes the entire space within the object.  If you 
select this draw method, you must specify the width of the 
f ield in the current unit of measure ( inches or mill imeters). 

♦  Regular Fit – PCMate prints the text or image normally, and 
the width of the object is determined by the Length you set.   
If the character string or image exceeds the width of the 
object, only characters or portions of the image that f it 
within the object appear.  If the character str ing or image is 
less than the width of the object, white space may appear 
after the text or image. 

Encoding Function 
Field 

For information about this feature, contact Avery Dennison 
Technical Support. 

Expansion 
♦  Height 
♦  Width 

♦  Text 
♦  Care 

Symbol 
♦  Picture 

This feature is not used at this t ime. 

Expansion/ 
Narrow Bar 

Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Field Posit ion 
(in) 
♦  Width Offset 
♦  Length 

Offset 

♦  Text 
♦  Barcode 
♦  Rectangle/

Line 
♦  Care 

Symbol 
♦  Picture 
♦  Function 

Field 

TEXT  
♦  Length Offset – Specif ies the feed posit ion of the upper 

left-hand corner of the f ield.  
♦  Width Offset – Specif ies the web position of the upper left-

hand corner of the f ield. 
 
RECTANGLE  
♦  Width Offset – Specif ies the web offset of the upper left-

hand corner of the f ield.  
♦  Length Offset – Specif ies the feed offset of the upper left-

hand corner of the f ield. 
 
CARE SYMBOL  
Set the position of the care symbol object on the label design:  
♦  Width Offset – Specif ies the web offset of the upper left 

corner of the f ield.   
♦  Length Offset – Specif ies the feed offset of the upper left 

corner of the f ield. 
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Properties Applicable 
Object(s) 

Description 

  PICTURE 
♦  Width Offset – Specif ies the web offset of the logo point of 

origin.  
♦  Length Offset – Specif ies the feed offset of the logo point 

of origin. 
For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Fixed Text ♦  Text 
♦  Barcode 
♦  Care 

Symbol 
♦  Function 

Field 
♦  Data Field 

♦  TEXT: Alphanumeric str ing used as default data for this 
f ield.  The field length and characters from the current code 
page limit this f ield.  Precanned data is the information 
entered when the design is created.  This data is 
automatically f i l led in when the f ield is printed. 

♦  CARE SYMBOL: Care symbol information entered when the 
design is created.  This information wil l automatically f i l l in 
the f ield during printing.  Care symbols can only be 
selected by number, for example, 15, 21, 30, and so on.  
Precanned information must follow this example, including 
comma separators.  Refer to the appendixes in the 
PCMate’s Label Printing Guide for the l ist of valid numbers 
and their corresponding care symbols. 

Str ing used to hold the type of function data.  This f ield is 
disabled for this type of f ield.  It is used as a placeholder to 
allow you to see which type of function you have selected.  
The printer wil l f i l l in this f ield with the corresponding data. 
For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Font 
♦  Bold 
♦  Italic 
♦  Underline 
♦  Str ike Thru 

♦  Text 
♦  Barcode 
♦  Care 

Symbol 
♦  Function 

Field 

♦  TEXT: If you are using a PC-resident font, check the 
character set for the text within the object to see if it  
supports the desired country language.  This sett ing does 
restr ict the use of this font.  If the language you want to 
select is not in the l ist, you may need to select or install 
another font that supports the desired language.   
To make fonts available, you must either install the font as 
a Windows font (Control Panel>Fonts) or, if  available as a 
printer-resident font, put the font f i le in the following 
working folder and install the font on your printer: 
C:\Paxarwin\Fonts 
Fonts in either location are available for download as a 
graphic.  However, only the fonts in the PCMate working 
folder are available for printer-resident fonts. 
If you install a new font, you must restart your PC. 

♦  BARCODE or FUNCTION FIELD: Windows fonts are not 
available for barcode and function f ield objects.  You must 
use printer-resident fonts instead.  

♦  CARE SYMBOL: This feature does not apply to care 
symbols. 

For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 
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Properties Applicable 
Object(s) 

Description 

Function Code ♦  Text 
♦  Barcode 

(Code 128 
only) 

♦  Data Field 

Select a function code to include special function characters 
in the code.  The appropriate function code will be added to 
the Fixed Text f ield. 
♦  FNC1 Function Code 1 – If this code is in the f irst or 

second posit ion following the f irst character, it  identif ies 
symbols that conform to a specif ic industry standard.  If 
this code is in any other position, it is used as a f ield 
separator. 

♦  FNC2 Function Code 2 – This code can occur anywhere in 
the symbol.  It instructs the reader to temporarily store data 
from the symbol containing the FNC2 character and 
transmit it as a pref ix to the next symbol data.  Use this 
code to concatenate several symbols before transmission.  
It is also known as Message Append.  

♦  FNC3 Function Code 3 – This code can occur anywhere in 
the symbol.  It instructs the reader to interpret the data 
from the symbol containing the FNC3 character as 
instructions for programming the reader.  It is also known 
as Initialize. 

♦  FNC4 Function Code 4 – This code provides access to an 
extended ASCII mode.  By using this code, data used from 
code sets A and B have their values increased by 128 from 
their normal ASCII values.  A single FNC4 code toggles in 
or out of extended ASCII mode for just a single data 
character that follows it.  Two consecutive FNC4 codes 
toggle the extended ASCII mode for all data characters 
following it unti l another double FNC4 code or end of the 
symbol is encountered. 

Function Type Function 
Field 

Select the type of function you want PCMate to perform to 
dynamically generate data for this object as follows:  
♦  Batch ID – 8-digit number assigned by PCMate to each 

batch in a print job.  The number is random for non-secure 
designs and controlled by D2Comm for secure designs.  

♦  Date – Current date of the printer clock. 
♦  Quantity – Quantity f ield sent to the printer. 
♦  Time – Time stamp of the printer. 
♦  Euro Date – As set by the printer. 
♦  User Security ID – As set by the combination of PCMate 

and D2Comm at the t ime of print. 
♦  SKU # – The line number when sending multiple batches to 

the printer; used on flagging for indication of 1 of 5, 2 of 5, 
3 of 5, and so on. 

♦  Fixed Text – Forced fixed data that cannot be altered by 
any autoimport or editing of saved batch data. 

Height ( in) Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Horizontal 
Alignment 

Picture This feature is not used at this t ime. 

Horizontal 
Justif ication 

♦  Text 
♦  Care 

Symbol 
♦  Function 

Field 

Set the alignment position of data within the object.  
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Properties Applicable 
Object(s) 

Description 

HRI Posit ion Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Guard Bar 
Extension 
(in/mm) 

Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

ICS (Dots) ♦  Text 
♦  Care 

Symbol 

This sett ing controls the Inter-Character Spacing.  Set the 
number of dots between characters for between care symbols. 

Input Direction ♦  Text 
♦  Care 

Symbol 

♦  Normal – Advances cursor in the direction given by the font 
selected (for example, English fonts cause cursor to move 
left to r ight; Hebrew fonts move the cursor from right to 
left). 

♦  Reverse – Advances cursor in the opposite direction of the 
font selected. 

Inverse Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Length ♦  Text 
♦  Barcode 
♦  Picture 
♦  Function 

Field 

♦  TEXT and FUNCTION FIELD: Set the maximum number of 
characters allowed within the object.  On the Details tab, 
you can use the Draw Method to configure the manner in 
which the characters appear within the object and adjust 
the width of the f ield if desired. 

♦  PICTURE: Set the length of the image fi le name. 
For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Line Width 
(Dots) 
♦  Vertical 
♦  Horizontal 

Rectangle/Li
ne 

Determines the thickness of the l ines of either the box or l ine. 
♦  Vertical – Specif ies the vertical line width. 
♦  Horizontal – Specif ies the horizontal line width. 

Logo Editor Picture This feature allows you to open your preferred graphic design 
editor to save time when edit ing image f iles. 

Max Segments 
Per Row 

Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Multi-Line 
♦  Number Of 

Lines 
♦  Interline 

Spacing 

Text ♦  Number Of Lines – Set the number of distinct l ines that 
PCMate uses to automatically f i l l data in the object via 
manual input or import of data.  

♦  Interline Spacing – Set the amount of “white space” in 
between each line. 

Number of 
Check Digits 

Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Number of 
Symbols 

Care Symbol Set the maximum number of care symbols allowed in the 
object. 

Override Batch 
ID 

Data Field If selected, allows this object to override the print job id on 
the printer front panel for non-secure mode.  The front panel 
instead displays whatever data is contained in the Fixed Text  
text box when it is ready to print downloaded print jobs.  The 
length of this data is l imited by the length of a print job id  
(8 characters). 
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Properties Applicable 
Object(s) 

Description 

Point Size ♦  Text 
♦  Barcode 
♦  Care 

Symbol 
♦  Function 

Field 

Set the size of the font for the data within the object, or the 
size of the care symbol set.  
For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Position Picture If you selected <VARIABLE> from the Set Name l ist box, the 
Position l ist box becomes active and shows all images in 
PCMate’s working directory.  If you select None, PCMate 
does not show a red frame or an image on the label design, 
which may make it diff icult to place other objects.  
If you selected a logo set from the Set Name  list box (a f i le 
name with an asterisk), the Position  l ist box becomes active 
and shows all of the available images in the logo set.  
Regardless of what you select, PCMate shows a red frame on 
the label design that represents the largest image in the logo 
set and outlines the posit ion and size of the object.  If you 
select a specif ic image from the logo set, PCMate displays the 
image as the default image on the label design, which can be 
overridden during an ODBC library lookup, manual data entry, 
or auto-import.  
If you selected a specif ic image fi le from the Set Name l ist 
box, this l ist box is inactive. 

Print Station ♦  Text 
♦  Barcode 
♦  Rectangle/

Line 
♦  Care 

Symbol 
♦  Picture 
♦  Function 

Field 

Select the print station of the printer to be used to print on 
different parts of the label.  For more information about print 
stations, see Chapter 2, “About Label Designs.” 
For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Prompt ALL Enter a unique name that identif ies the object.  The object 
name is the same as the f ield name that printer operators see 
when they open print jobs for data entry, selection, ordering, 
and/or copying.  If you are adding an object that is going to be 
populated from an ODBC-compliant data source fi le, you may 
want to name the object something similar to the data in the 
data source fi le. 
For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Rotation ♦  Text 
♦  Barcode 
♦  Care 

Symbol 
♦  Picture 
♦  Function 

Field 

Select the orientation of the object on the label. 
For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Ratio Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 
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Properties Applicable 
Object(s) 

Description 

Security Level Function 
Field 

Select the level of security you want to apply as follows: 
♦  Lot/SKU Level – Applies a unique serial number to each 

batch, and applies the serial number to all labels in the 
batch. 

♦  Ticket Level – Applies a unique serial number to each label 
in every batch. 

Segmentation Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Set Name Picture Select which option you want to use to input your image fi le: 
♦  <VARIABLE> – This inserts the object as a placeholder for 

image fi les with a non-structured naming convention.  If 
you select <VARIABLE>, PCMate does not show a red 
frame on the label design, which may make it diff icult to 
place other objects.  We recommend temporarily selecting 
an image from the Position l ist box that represents the 
largest image that could be placed in the object so that you 
can see the posit ion and size of the object on the label 
design. 

♦  Logo set – This inserts the object as a placeholder for 
image fi les with a structured naming convention.  If you 
select a logo set ( image fi le name contains an asterisks 
(*)), PCMate shows a red frame that represents the largest 
image in the set and outlines the posit ion and size of the 
object on the label design.  

♦  Specif ic image fi le – This inserts the object as a 
placeholder for image fi les with a non-structured naming 
convention and inputs the image fi le you select as the 
default image on the label design.  If you are creating the 
label design for use with an ODBC library lookup, manual 
data entry, or auto-import, the image f ile name must match 
the variable input data so that PCMate overwrites the 
default image and print the desired image. 

Note: Logo fi les must be in the following default working 
folder: C:\Paxarwin\Logos  

Show HRI Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Soft Break 
Characters 

Text If you configure this object to have multiple l ines, set the 
number of break characters in addit ion to a “space” for 
wrapping data to the next l ine.  
Note: In a print job, CTRL+ENTER is the command that 

invokes a hard break in a multi-l ine object and forces 
the next character to start on the next line.   

Start Character Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Stop Character Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Subset Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

System Digit X 
Position (Dots) 

Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 
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Properties Applicable 
Object(s) 

Description 

System Digit Y 
Position (Dots) 

Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Type Rectangle/ 
Line 

Select the type of box (f il led or outline) or l ine (vertical, 
horizontal, and diagonal) to create. 

UPC 
Supplement 

Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Uppercase Text If you want the text to be forced to UPPERCASE, select this 
checkbox.  If you want the characters to appear as entered 
into the object, clear this checkbox. 

Vertical 
Alignment 

Picture This f ield is not used at this t ime. 

Vertical Text Text If you want text to be entered vertically into the object, select 
this checkbox and the cursor advances from top to bottom as 
characters are typed. 

Width (in/mm) Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Write Mode ♦  Text 
♦  Rectangle/

Line 
♦  Care 

Symbol 
♦  Picture 
♦  Function 

Field 

Select the manner in which you want PCMate to handle this 
object in the event data within another object occupies the 
same posit ion as all or part of the data in this object as 
follows: 

Direct 

 

Overlap 

 

Inverse 

 

The order in which you add objects to the label design is 
important because it determines which object overlays the 
other.  For each example shown above, the f irst object added 
to the label design is the barcode object.  The second object 
added to the label design is the picture object.  Also, the 
Write Mode for the barcode object is Direct . 

X Undercut Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 

Y Undercut Barcode For information about properties for barcode objects, see 
Chapter 5, “About Barcode Objects.” 
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A b o u t  F i e l d  T a g s  P r o p e r t i e s  f o r  O b j e c t s  
Each object has field tag properties that allow you to set up attributes for editing and 
printing. 

 
 
The following table provides a description of the field tag properties for an object. 
 
Field / Field Set Description 

Macro 
♦  Key Field 
♦  Target 
♦  Trigger Lookup 

Use these checkboxes to indicate whether the object is part of a macro 
lookup as follows: 
♦  Key Field – Select this checkbox if the object is a key.  In a print job, a 

key object becomes a key f ield in which the printer operator or the 
Auto-Import Routine inputs a text value that l inks to variable data 
required for one or more target f ields.  A label design can have 
multiple key f ields.  Also, a key f ield can be designated as a target 
f ield in which PCMate overwrites the key during the lookup. 

♦  Target – Select this checkbox if the object is a target.  In a print job, a 
target object becomes a target f ield in which PCMate populates data 
after performing a lookup.  A label design can have multiple target 
objects. 

♦  Trigger Lookup – Select this checkbox if the object is a tr igger.  In a 
print job, the tr igger objects becomes the tr igger f ield that executes 
the data lookup – using key f ields to populate data in target f ields. 

For information about macro lookups, see Chapter 9, “Working with 
Macro Lookups.” 

4-12  Label Design Guide   



Field / Field Set Description 

Library 
♦  Dos Library Key 

Field 
♦  Trigger Lookup 

Use these checkboxes to indicate whether the object is part of an ODBC 
lookup as follows: 
♦  Key Field – This checkbox is not used. 
♦  Trigger Lookup – Select this checkbox if the object is a tr igger.  In a 

print job, the tr igger objects becomes the tr igger f ield that executes 
the data lookup – using key f ields to populate data in target f ields. 

For information about lookups in ODBC-compliant data source fi les, see 
Chapter 8, “Working with Odbc Library Lookups.” 

Order 
♦  Library First 
♦  Macro First 

If the object is part of a macro lookup and an ODBC lookup, select which 
lookup you want PCMate to perform first.  
♦  Library First – Select this button for PCMate to perform an ODBC 

lookup before attempting a macro lookup. 
♦  Macro First – Select this button for PCMate to perform a macro lookup 

before attempting an ODBC lookup. 

Append Checksum If selected, PCMate automatically calculates and appends the checksum 
to a barcode object. 

Constant Field If selected, PCMate copies data in this object to the same object when 
creating a new print job.   

Flagging Field This option allows you to dynamically set f lagging options on a print  
job-by-print job basis.  Note that PCMate only uses data for the f irst 
f lagging object on the label design.  If you have more than one object 
marked as a f lagging object, PCMate only send flagging data for the f irst 
f lagging object it encounters and ignores data in all subsequent f lagging 
objects. 
Also, note that you may enter f lagging commands in either uppercase or 
lowercase characters, and that PCMate ignores invalid f lagging 
commands.  To use this feature, you need to enter (as precanned or in 
the print job as variable data) the letter indicating the type of f lag, 
followed by a ‘: ’,  followed by a number (the number indicates the quantity 
the sub print job).  The valid f lagging indicators are printer specif ic (see 
your printer manual) but include V: (verif ier Flag), B: (Double Blank),  
S: (Small), M: (Medium), X: (Extra Large) and Z: (Zero Length). 

Logfile Field / 
Include Field Name 

If you want to log data for the current object into a log f ile, select this 
checkbox.  Each time PCMate downloads a print job to the printer, 
PCMate saves the contents of the object, including the object name, to 
the logfile.txt  f ile that resides in the installation directory.  Avery 
Dennison Web Services can then track the information so that you can 
view historical printed data online.  For information about this feature, 
contact Avery Dennison Technical Support. 

Mandatory Input If selected, you cannot send print jobs to the printer without entering data 
into this f ield. 

RFID Data Field / 
Read Only / Lock 
Code 

PCMate uses this feature to commission RFID labels.  For information 
about this feature, contact Avery Dennison Technical Support. 

Request Printed 
Data 

PCMate uses this feature to commission RFID labels.  For information 
about this feature, contact Avery Dennison Technical Support. 

Create New Batch 
After Edit 

In an open print job, if  you want PCMate to automatically create a new 
batch after data is entered into this f ield, select this checkbox.  If you 
want the printer operator to create new batches manually, clear this 
checkbox. 
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Field / Field Set Description 

Next Field to Edit In an open print job, if  you want PCMate to automatically place the cursor 
in a specif ic f ield after entering data into this f ield, select the f ield that 
should be next.  
Note: You must select the Create New Batch After Edit  checkbox for 

this option to become active. 

Validation If you want PCMate to validate data in this f ield, select the check you 
want PCMate to perform.  These checks are based on customer 
specif ications, such as Montgomery Ward and Sears. 

Template If you want PCMate to use an input template, select the template.  One 
example is Price, which prepends a dollar sign (‘$’) character in front of 
the numeric data in this f ield.  It also inserts two digits to the left of the 
least signif icant number, turning 1345 into $123.45.  Currently, the 
available templates are Price and OCRA Price. 

Perform Cut Field This option controls the number of labels PCMate should print prior to a 
cut taking place.  For example, if  you input a 5 into this object, PCMate 
prints and cuts 5 labels, followed by 5 more labels, then a cut.  If you 
input a 0 into this object, PCMate prints all labels in the print job prior to 
a cut. 

Tag Background 
Key Field 

For information about this feature, see Chapter 3, “Working with Label 
Designs.” 

User Security Key 
Field 

PCMate uses this feature for serialization with Avery Dennison Web 
Services.  For information about this feature, contact Avery Dennison 
Technical Support. 

Access Password 
Field 

PCMate uses this feature to commission RFID labels.  For information 
about this feature, contact Avery Dennison Technical Support. 

Kil l Password Field PCMate uses this feature to commission RFID labels.  For information 
about this feature, contact Avery Dennison Technical Support. 

Field Security This option provides for data security by allowing only those with proper 
authorization to access the f ield. 
♦  Display / Editable Field – Allows you to hide data in an open print job.  

If checked, the data displays in an open print job 
♦  Editable Only Before Library Lookup – Allows you to change data in 

the f ield before a successful macro or ODBC lookup occurs 
♦  Editable By User Level – Indicates the level of security needed to be 

able to edit this f ield as follows: 1 – standard user, 2 – administrator,  
3 – administrator 
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A b o u t  B a t c h  C o p y  P r o p e r t i e s  f o r  O b j e c t s  
Each object has batch copy properties that allow you to set up incrementing fields.  You 
can also reuse data from previous print jobs. 

 
The following table provides a description of the batch copy properties for an object. 
 
Properties Description 

Label Increment 
♦  Increment By 
♦  Number Of 

Duplicates  
♦  Pad With Leading 

Zeros  

♦  Increment By – Specif ies automatic numbering of this object for each 
tag or label in a single print job.  For example, you can increment the 
starting number of a text object or barcode object by placing a non-
zero value in this box.  Since the incrementing is performed on a per-
print job basis, the init ial starting value resets to the value in the 
object for each print job. 

♦  Number Of Duplicates – Changes the number of tags or labels printed 
before incrementing to the next number. 

♦  Pad With Leading Zeros – Pads incremented numbers with zeros. 

Previous Batch 
Copy 
♦  Increment  
♦  Add Quantity  
♦  Pad with Zeros  

♦  Increment – Increments the selected object’s value from the previous 
print job when a new print job is created.  You must select a valid 
object to copy from before you can modify this checkbox. 

♦  Add Quantity – Copies the selected object’s data from the previous 
print job and adds the quantity to it when a new print job is created.  
You must select a valid f ield to copy from before you can modify this 
checkbox. 

♦  Pad with Zeros – Copies the selected object’s data from the previous 
print job and pads it with zeros if it  is shorter than the object length.  
You must select a valid object to copy from before you can modify 
this checkbox. 
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A b o u t  S u b s t r i n g  P r o p e r t i e s  f o r  O b j e c t s  
Each object has substring properties that allow you to incorporate the merge and split 
features to copy variable data from other objects into a new target object. 

 
You can parse data from any number of source objects into a target object. The Add, 
Update, Delete, Move Up, and Move Down buttons allow you to configure data that 
makes up the substring and, ultimately, determines the data for the target object you are 
creating. The Current Links list shows the substrings you have added to the target object 
you are creating. The source object name appears in the first set of brackets, and the 
character positions appear in the second set of brackets. In the figure above, the name of 
the source object is UPC, and the characters to copy from the UPC object are characters 
2 to 6. 
The table below provides a description of the substring properties for an object. 
 
Properties Description 

Field List Select a source object from which you want to copy data to populate the 
object you are edit ing.  Objects that appear in ALL CAPS are provided by 
PCMate.  All other objects in the l ist are objects that you have added to 
the label design. 

Data Conversion This is a security and EPC function.  For information about this feature, 
contact Avery Dennison Technical Support. 

Start Character 
Position 

Select the f irst character to copy from the selected source object.   You 
must select a source object from the Field List l ist box before you can 
select the starting character posit ion. 

4-16  Label Design Guide   



Properties Description 

Number of 
Characters to Copy 

Select the number of characters, starting with the f irst character posit ion, 
to copy from the selected source object.  You must select a source object 
from the Field List  list box before you can select the number of 
characters to copy. 

Append to Str ing If you want PCMate to keep any existing f ixed text this this target objet 
and append the substring data to it, select this checkbox.  If you want 
PCMate to ignore any f ixed text in this target object and include parsed 
data from the source object(s) only, clear this checkbox.  
Note: Each object supports a f ixed number of characters.  If you select 

this checkbox, there must be enough open space within the object 
for the parsed data to f it.  For example, if  the object you are edit ing 
is configured to hold 10 characters and already has 5 characters of 
data, the most number of characters that you can copy to the 
object is 5. 

Trim If you want PCMate to overwrite any existing data with input data that is 
parsed from the source object(s), select this checkbox.  If, for example, 
the object you are edit ing is configured to hold 10 characters and already 
has 5 characters of data, PCMate deletes existing data to input parsed 
data from the source object(s). 
If you want PCMate to leave any existing data and only input the amount 
of parsed data that can fit into the object, clear this checkbox. 

Perform Datacopy 
In Printer 

If you want your printer and/or PCMate to parse data into the object you 
are edit ing, select this checkbox. 
If you are using special designs where an incrementing print job can only 
be sent to the printer once to prevent the possibil ity of duplicate serial 
numbers, you must select this checkbox so the printer, not PCMate, 
parses data into the object you are edit ing.  If the printer parses data, the 
object can only be populated one time. If PCMate parses data, the object 
can be populated any number of times. 
Note: The printer can only parse substr ing data for one object on your 

label design.  If you select this checkbox, make sure there is only 
one object that has parsed data. 

 
For an example of how to create objects by parsing data from other objects, see Chapter 
6, “Working with Objects.” 
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A B O U T  B A R C O D E  O B J E C T S  
PCMate supports over 20 types of barcodes.  In this chapter, you can learn about 
barcode/printing compatibility, as well as how to configure properties for each of the 
following types of barcodes: 

♦ UPC-A 
♦ UPC-E 
♦ EAN-13 
♦ EAN-8 
♦ Code 39 
♦ Interleaved 2 of 5  
♦ Code 128  
♦ Code 128 E.D.I. 

♦ Code 93  
♦ GS1 DataBar  
♦ Data Matrix  
♦ MaxiCode  
♦ PDF417  
♦ QR Codes 
♦ Custom Bar Codes 
 

 

A b o u t  B a r c o d e / P r i n t e r  C o m p a t i b i l i t y  
PCMate is compatible with over 20 different printer models.  When you are creating a 
label design that has a barcode, be sure to use a barcode that is compatible with the 
target printer selected for the label design.  In addition, you need to know whether the 
barcode type you select is PC-resident or printer-resident.  PC-resident means the 
barcode image is not generated by the printer’s f irmware and must be downloaded to the 
printer as a graphic image with other print job information to print on a label.  Printer 
resident means the barcode image is generated in the printer’s firmware and print on 
labels.  Some printers support both PC-resident and printer-resident barcodes, while 
other printers have restrictions.  
The table below provides a list of barcode types and indicates your options for each 
printer.  Both means the printer model supports both pc-resident and printer-resident 
barcode types, and you have the option of whether you want to download the barcode 
image to the printer with the other print job information.  Not supported means the printer 
model does not support the barcode type. 
 
Barcode Type 640x SNAP 98xx 6x6 Xerox Laser 

Code 39 Both Both Both Both Printer-resident 

Code 93 Both Both Both Both Printer-resident 

Code 128 Both Both Both Both Printer-resident 

Code 128 E.D.I. Both Both Both Both Printer-resident 

Data Matrix (ALPHA) Printer-resident Printer-resident Printer-resident Printer-resident Printer-resident 

Data Matrix (ASCII) Printer-resident Printer-resident Printer-resident Printer-resident Printer-resident 

Data Matrix (NUMERIC) Printer-resident Printer-resident Printer-resident Printer-resident Printer-resident 

EAN-8 Both Both Both Both Printer-resident 

EAN-13 Both Both Both Both Printer-resident 

GS1 DataBar Not Supported Both Printer-resident Both Printer-resident 

Interleaved 2 of 5  
(includes all ratios) Both Both Both Both Printer-resident 

5  
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Barcode Type 640x SNAP 98xx 6x6 Xerox Laser 

MaxiCode Not Supported Not Supported Both Not Supported Printer-resident 

PDF417 Not Supported Not Supported Both Not Supported Printer-resident 

PUMA Code 128 PC-resident Both Not Supported Both Not Supported 

QR Printer-resident Printer-resident Printer-resident Printer-resident Printer-resident 

SEARS Code 39 Not Supported Both Not Supported Both Not Supported 

UPC-A Both Both Both Both Printer-resident 

UPC-E Both Both Both Both Printer-resident 
 
A b o u t  U P C - A  B a r c o d e s  
The UPC-A barcode has a strip of black bars and white 
spaces, above a sequence of 12 numerical digits.  UPC-A 
barcodes do not support letters, characters, or other 
content.  The digits and bars maintain a one-to-one 
correspondence.  There is only one way to represent 
each 12-digit number visually, and there is only one way 
to represent each visual barcode numerically. 
The scannable area of every UPC-A barcode follows the 
same pattern: 
SLLLLLLMRRRRRRE 

S represents the starting guard bar.  M represents the 
middle guard bar, and E represents the end guard bar.  The L (left) and R (right) sections 
collectively represent the 12 numerical digits that make each UPC unique.  The first digit 
L is the prefix.  The last digit R is an error correcting check digit.  The guard bars, which 
are non-numerical digits, separate the two groups of six digits and establish the timing. 
The table below provides a description of the properties for a UPC-A barcodes. 
 
Properties Applicable 

Printers 
Description 

Barcode Type All printers Select UPC-A.  

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

All printers If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 
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Properties Applicable 
Printers 

Description 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font All printers If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 640x printers are required to use Font 4 (6 point).  

98xx printers are required to use 9 PT. CG 
TRIUMVIRATE BOLD.   
Laser printers use a default font. 

Guard Bar 
Extension 
(in/mm) 

♦  640x 
♦  98xx  
♦  Laser 

Set the vertical offset of guard bars from barcode base either 
in inches or millimeters depending on the ruler that shows 
your label design orientation. 

Height ( in/mm) All printers Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion All printers If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 

Inverse ♦  SNAP 
♦  640x 
♦  6x6  
♦  98xx 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation All printers Select the orientation of the barcode on the label design. 

Show HRI All printers If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 
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Properties Applicable 
Printers 

Description 

Segmentation All printers Select the manner in which you want PCMate to group the 
numbers that appear under the barcode. 

System Digit X 
Position (Dots) 

♦  640x 
♦  98xx  
♦  Laser 

Set the position of the human readable data left and r ight.  

System Digit Y 
Position (Dots) 

♦  640x  
♦  Laser 

Set the position of the human readable data up and down. 

UPC Supplement ♦  SNAP 
♦  6x6  
♦  98xx 

UPC-A barcodes can include an addit ional barcode to the 
right of the main barcode symbol.  This second barcode, 
which is usually not as tall as the primary barcode, can 
encode addit ional information.  If desired, select the type of 
supplement to add to the barcode as follows:  

None 

 

2-character 

 

5-character 

 
  

A b o u t  U P C - E  B a r c o d e s  
A UPC-E barcode is a “zero-compressed” version of UPC developed for use 
on labels where a full 12-digit barcode may not f it.  The UPC-E barcode 
differs from UPC-A in that it only uses a 6-digit code, does not use middle 
guard bars, and the end bit pattern (E) becomes 010101.  
 
 
 
The table below provides a description of the properties for a UPC-E 
barcodes. 

Properties Applicable 
Printers 

Description 

Barcode Type All printers Select UPC-E. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

All printers If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 
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Properties Applicable 
Printers 

Description 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font All printers If you select the Show HRI checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 640x printers are required to use Font 4 (6 point).  

98xx printers are required to use 9 PT. CG 
TRIUMVIRATE BOLD.   
Laser printers use a default font. 

Guard Bar 
Extension 

640x Set the vertical offset of guard bars from barcode base either 
in inches or millimeters depending on the ruler that shows 
your label design orientation. 

Height ( in/mm) All printers Set the height of the barcode on the label design in either 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion All printers If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 

Inverse ♦  SNAP 
♦  640x 
♦  6x6 
♦  98xx 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 
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Properties Applicable 
Printers 

Description 

Rotation All printers Select the orientation of the barcode on the label design 

Show HRI All printers If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

Segmentation ♦  640x 
♦  98xx 

Select the manner in which you want PCMate to group the 
numbers that appear under the barcode. 

System Digit X 
Position (Dots) 

640x Set the position of the human readable data left and r ight.  

System Digit Y 
Position (Dots) 

640x Set the position of the human readable data up and down. 

PC Supplement ♦  SNAP 
♦  6x6 
♦  98xx 

UPC-E barcodes can include an addit ional barcode to the 
right of the main barcode symbol.  This second barcode, 
which is usually not as tall as the primary barcode, can 
encode addit ional information.  If desired, select the type of 
supplement to add to the barcode as follows: 

None 

 

2-character 

 

5-character 
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A b o u t  E A N - 1 3  B a r c o d e s  
An EAN-13 barcode is a 13 digit (12 data and 1 check) barcode, 
which is a superset of the original 12-digit UPC barcode.  The 
EAN-13 barcode encodes numbers that represent product 
identif ication numbers.  All the numbers encoded in UPC and EAN 
barcodes are known as Global Trade Item Numbers (GTIN), and 
they can be encoded in other GS1 barcodes. 
  
 
The table below provides a description of the properties for an 
EAN-13 barcodes.  
 
Properties Applicable 

Printers 
Description 

Barcode Type All printers Select EAN-13. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

All printers If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto-import, manual entry or ODBC 
library look up. 

Font All printers If you select the Show HRI checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 640x printers are required to use Font 4 (6 point).  

98xx printers are required to use 9 PT. CG 
TRIUMVIRATE BOLD.  Laser printers use a default 
font. 

Guard Bar 
Extension 

♦  640x 
♦  98xx 

Set the vertical offset of guard bars from barcode base either 
in inches or millimeters depending on the ruler that shows 
your label design orientation. 

Height ( in/mm) All printers Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 
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Properties Applicable 
Printers 

Description 

HRI Posit ion All printers If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 

Inverse ♦  SNAP 
♦  6x6 
♦  98xx 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation All printers Select the orientation of the barcode on the label design 

Show HRI All printers If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

Segmentation All printers Select the manner in which you want PCMate to group the 
numbers that appear under the barcode. 

System Digit X 
Position (Dots) 

♦  640x 
♦  98xx 

Set the position of the human readable data left and r ight.  

System Digit Y 
Position (Dots) 

640x Set the position of the human readable data up and down. 

UPC Supplement ♦  SNAP 
♦  6x6 
♦  98xx 

Select the type of supplement to add to the barcode as 
follows: 

None 

 

2-character 

 

5-character 
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A b o u t  E A N - 8  B a r c o d e s  
An EAN-8 barcode is a barcode is derived from the longer EAN-13 
barcode and was introduced for use on small labels where an EAN-
13 barcode would be too large.  
 
 
 
The table below provides a description of the properties for an 
EAN-8 barcodes.    
 
Properties Applicable 

Printers 
Description 

Barcode Type All printers Select EAN-8. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

All printers If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font All printers If you select the Show HRI checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 640x printers are required to use Font 4 (6 point).  

98xx printers are required to use 9 PT. CG 
TRIUMVIRATE BOLD.   Laser printers use a default 
font. 

Guard Bar 
Extension 

All printers Set the vertical offset of guard bars from barcode base either 
in inches or millimeters depending on the ruler that shows 
your label design orientation. 

Height ( in/mm) All printers Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 
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Properties Applicable 
Printers 

Description 

HRI Posit ion All printers If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 

Inverse ♦  SNAP 
♦  640x 
♦  6x6 
♦  98xx 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation All printers Select the orientation of the barcode on the label design 

Show HRI All printers If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

Segmentation All printers Select the manner in which you want PCMate to group the 
numbers that appear under the barcode. 

UPC Supplement ♦  SNAP 
♦  6x6 
♦  98xx 

EAN-8 barcodes can include an addit ional barcode to the 
right of the main barcode symbol.  This second barcode, 
which is usually not as tall as the primary barcode, can 
encode addit ional information.  If desired, select the type of 
supplement to add to the barcode as follows: 

None 

 

2-character 

 

5-character 
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A b o u t  C o d e  3 9  B a r c o d e s  
A Code 39 barcode is a variable length, discrete 
barcode that encodes 43 characters, consisting of 
uppercase letters (A through Z), numeric digits (0 
through 9) and a number of special characters (-, ., 
$, /, +, %, and space) and includes an additional 
character (denoted '*') for both start and stop 
delimiters.   
 
The table below provides a description of the properties for a Code 39 barcode.  
 
Properties Applicable 

Printers 
Description 

Barcode Type All printers Select CODE 39. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

All printers If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font All printers If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 640x printers are required to use Font 4 (6 point).  

98xx printers are required to use 9 PT. CG 
TRIUMVIRATE BOLD.   
Laser printers use a default font. 

Height ( in/mm) All printers Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 
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Properties Applicable 
Printers 

Description 

Inverse ♦  SNAP 
♦  640x 
♦  6x6 
♦  98xx 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Ratio ♦  SNAP 
♦  6x6 
♦  98xx  
♦  Laser 

Select the narrow to wide bar ratio (the width from the narrow 
bar to the wide bar). 

Rotation All printers Select the orientation of the barcode on the label design 

Show HRI ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

Segmentation ♦  SNAP 
♦  6x6  
♦  Laser 

Select the manner in which you want PCMate to group the 
numbers that appear under the barcode. 
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A b o u t  I n t e r l e a v e d  2  o f  5  B a r c o d e s  
An Interleaved 2 of 5 barcode is a continuous two-width 
barcode that encodes pairs of digits.  The first digit is 
encoded in the five bars (or black lines), while the 
second digit is encoded in the five spaces (or white lines) 
interleaved with them.  Two out of every five bars or 
spaces are wide (hence exactly 2 of 5).    
 
The table below provides a description of the properties 
for an Interleaved 2 of 5 barcode.  
 
Properties Applicable 

Printers 
Description 

Barcode Type All printers If you are creating a label design and the target printer is a 
SNAP, 640x, 6x6, or Xerox Laser, select INTERLEAVED 2 
OF 5.  If your target printer is a 98xx, select the barcode type 
as follows: 
♦  INTERLEAVED 2 0F 5 (2.0:1) 
♦  INTERLEAVED 2 0F 5 (2.3:1) 
♦  INTERLEAVED 2 0F 5 (2.5:1) 
♦  INTERLEAVED 2 0F 5 (3.0:1) 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

All printers If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font All printers If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 640x printers are required to use Font 4 (6 point).  

98xx printers are required to use 9 PT. CG 
TRIUMVIRATE BOLD.  Laser printers use a default 
font. 
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Properties Applicable 
Printers 

Description 

Height ( in/mm) All printers Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 

Inverse ♦  SNAP 
♦  640x 
♦  6x6 
♦  98xx 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Ratio ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

Select the narrow to wide bar ratio (the width from the narrow 
bar to the wide bar). 

Rotation All printers Select the orientation of the barcode on the label design 

Show HRI ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.   
If you want PCMate to just print the barcode, clear this 
checkbox. 
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A b o u t  C o d e  1 2 8  B a r c o d e s  
A Code 128 barcode is a high-density barcode used 
for alphanumeric or numeric-only barcodes.  It can 
encode all 128 characters of ASCII and, by use of 
an extension character (FNC4), the Latin-1 
characters defined in ISO/IEC 8859-1.  
The table below provides a description of s 
properties for a Code 128 barcode. 
 
Properties Applicable 

Printers 
Description 

Barcode Type All printers Select CODE 128. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

♦  SNAP 
♦  640x 
♦  6x6 
♦  98xx 

If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font All printers If you select the Show HRI checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 640x printers are required to use Font 4 (6 point). 

98xx printers are required to use 9 PT. CG 
TRIUMVIRATE BOLD.  Laser printers use a default 
font. 

Function Code ♦  SNAP 
♦  98xx 

Select a function code to include special function characters 
in the code.  The appropriate function code will be added to 
the Fixed Text f ield. 
♦  FNC1 Function Code 1 – If this code is in the f irst or 

second posit ion following the f irst character, it  identif ies 
symbols that conform to a specif ic industry standard.  If 
this code is in any other position, it is used as a f ield 
separator. 

♦  FNC2 Function Code 2 – This code can occur anywhere in 
the symbol.  It instructs the reader to temporarily store 
data from the symbol containing the FNC2 character and 

About Barcode Objects   5-15   



Properties Applicable 
Printers 

Description 

transmit it as a pref ix to the next symbol data.  Use this 
code to concatenate several symbols before transmission.  
It is also known as Message Append. 

  ♦  FNC2 Function Code 2 – This code can occur anywhere in 
the symbol.  It instructs the reader to temporarily store 
data from the symbol containing the FNC2 character and 
transmit it as a pref ix to the next symbol data.  Use this 
code to concatenate several symbols before transmission.  
It is also known as Message Append. 

♦  FNC3 Function Code 3 – This code can occur anywhere in 
the symbol.  It instructs the reader to interpret the data 
from the symbol containing the FNC3 character as 
instructions for programming the reader.  It is also known 
as Initialize. 

♦  FNC4 Function Code 4 – This code provides access to an 
extended ASCII mode.  By using this code, data used from 
code sets A and B have their values increased by 128 
from their normal ASCII values.  A single FNC4 code 
toggles in or out of extended ASCII mode for just a single 
data character that follows it.  Two consecutive FNC4 
codes toggle the extended ASCII mode for all data 
characters following it unti l another double FNC4 code or 
end of the symbol is encountered. 

Height ( in/mm) All printers Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 

Inverse ♦  SNAP 
♦  640x 
♦  98xx  
♦  Laser 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 
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Properties Applicable 
Printers 

Description 

Rotation All printers Select the orientation of the barcode on the label design 

Show HRI ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

Subset ♦  SNAP 
♦  98xx 

Specify a CODE 128 subset: 
♦  Auto – Select to allow the printer to determine the most 

appropriate code subset to use: 128A (code set A), 128B 
(code set B), or 128C (code set C). 

♦  Subset A – Select to force use of code set A.  When 
selected, the Download Barcode as Graphic is selected 
automatically, and the barcode is sent to the printer as a 
graphic. 

Width (in/mm) All printers Set the maximum width of the barcode on the label design 
either in inches or mill imeters depending on the ruler that 
shows your label design orientation.  PCMate truncates any 
portion of the barcode extending beyond the width you enter.  
Warning: PCMate sets the width according to the barcode 

Expansion and Length .  If you decrease the 
width, you may lose barcode data.  

A b o u t  C o d e  1 2 8  E . D . I .  B a r c o d e s  
The table below provides a description of the properties for a Code 128 E.D.I. barcode. 
 
Properties Applicable 

Printers 
Description 

Barcode Type All printers 
 

Select CODE 128 E.D.I . 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers 
 

If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

All printers 
 

If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers 
 

Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers 
 

You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 
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Properties Applicable 
Printers 

Description 

Font ♦  SNAP 
♦  640x 
♦  6x6 

If you select the Show HRI checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 640x printers are required to use Font 4 (6 point). 

Height ( in/mm) All printers 
 

Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode. 
For SNAP, 6x6, and Xerox Laser printers, PCMate always 
prints the text at the top (above) the barcode.  For 640x, you 
can select the top or the bottom. 

Inverse ♦  SNAP 
♦  640x 
♦  6x6 
♦  98xx 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers 
 

Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 
For SNAP printers, PCMate always prints the text using 10-
point size font.  For 6x6 printers, PCMate always prints the 
text using 24-point size font. 

Print Station All printers 
 

Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers 
 

Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation All printers 
 

Select the orientation of the barcode on the label design 

Show HRI ♦  SNAP 
♦  640x 
♦  6x6  
♦  Laser 

If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

Segmentation All printers 
 

Select the manner in which you want PCMate to group the 
numbers that appear under the barcode. 
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A b o u t  C o d e  9 3  B a r c o d e s  
A Code 93 barcode encodes 26 upper case letters, 10 
digits and 7 special characters.  In addition to 43 
characters, Code 93 defines 5 special characters 
(including a start/stop character), which can be combined 
with other characters to unambiguously represent all 128 
ASCII characters.  Every symbol includes two check 
characters. 
 
The table below provides a description of the properties 
for a Code 93 barcode. 
 
Properties Applicable 

Printers 
Description 

Barcode Type All printers Select CODE 93. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

All printers If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

All printers If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

If you select the Show HRI checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 
Note: 98xx printers are required to use 9 PT. CG 

TRIUMVIRATE BOLD.   Laser printers use a default 
font. 

Height ( in/mm) All printers Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion ♦  SNAP 
♦  640x 
♦  6x6 
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 
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Properties Applicable 
Printers 

Description 

Inverse ♦  SNAP 
♦  98xx 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6 
♦  Laser 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation All printers Select the orientation of the barcode on the label design 

Segmentation ♦  SNAP 
♦  6x6 
♦  Laser 

Select the manner in which you want PCMate to group the 
numbers that appear under the barcode. 

Show HRI ♦  SNAP 
♦  640x 
♦  6x6 
♦  Laser 

If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

Width (in/mm) All printers Set the maximum width of the barcode on the label design 
either in inches or mill imeters depending on the ruler that 
shows your label design orientation.  PCMate truncates any 
portion of the barcode extending beyond the width you enter.  
Note: PCMate sets the width according to the barcode 

Expansion and Length .  If you decrease the width, 
you may lose barcode data. 
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A b o u t  G S 1  D a t a B a r  B a r c o d e s  
A GS1 DataBar barcode encodes a GTIN-12 or GTIN-13 
in a 14-digit data structure.  
 
 
 
The table below provides a description of the properties 
you can configure for a GS1 DataBar barcode.   
 
Properties Applicable 

Printers 
Description 

Barcode Type ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select GS1 DataBar. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

GS1 Barcode 
Format 

♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select the barcode symbol you want to use as follows: 
♦  Omnidirectional 
♦  Truncated 
♦  Stacked 
♦  Stacked Omni 
♦  Limited 
♦  Expanded (Alpha) 
♦  Expanded (Numeric) 

Height ( in/mm) Laser Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 
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Properties Applicable 
Printers 

Description 

Length ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Set the maximum number of characters that can be encoded 
in the barcode. 

Max Segments 
Per Row 

♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Set the maximum number of segments per row for each 
stacked barcode line. 

Print Station ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select the orientation of the barcode on the label design 

X Undercut ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Set the X undercut value from 0 to 14. 

Y Undercut ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Set the Y undercut value from 0 to 14. 

 

A b o u t  D a t a  M a t r i x  B a r c o d e s  
A Data Matrix barcode is two-dimensional and consists of 
black and white "cells" or modules arranged in either a 
square or rectangular pattern.  You can encode text and/or 
numeric data.  The length of the encoded data depends on 
the number of cells in the matrix.  Data Matrix barcodes use 
error checking and error correction codes (ECCs) to 
increase reliability.  Even if one or more cells are damaged, 
data can still be read.     
As indicated earlier in this chapter, all PCMate-compatible 
printer families support Data Matrix barcodes as follows: 
♦ All Data Matrix barcodes must adhere to ISO standard 

16022:2006. 
♦ The 640x, SNAP, and 9855 resident operating systems 

only support ECC 200 error correction codes. 
♦ The following older generation error correction codes 

are not supported by PCMate with any printer family: ECC 000, 050, 080, 100, 140.  
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Data Matrix barcodes are efficient with numbers, meaning more characters are supported 
in a given symbol size.  When you interchange numbers, alpha, and punctuation 
characters, less characters are supported in the same symbol size.  For example, if you 
create a Data Matrix barcode using a 20x20 symbol size, the barcode holds up to 44 
numeric characters, at least 31 alphanumeric characters, and at least 20 ASCII 
characters (alphanumeric and punctuation).  
The table below provides a description of the properties you can configure for a Data 
Matrix barcode. 
 
Properties Applicable 

Printers 
Description 

2D Features All printers Select the barcode symbol size.  Based on your selection, 
PCMate automatically calculates and populates values for 
the Length , Height,  and Width text boxes. 
Note: The values for the Height and Width  are also affected 

by the value you enter for the Expansion/Narrow Bar. 

Barcode Type All printers Select the format in which the data is encoded as follows: 
♦  DATA MATRIX (Alpha) – Select this type of Data Matrix 

barcode if the encoded data is a combination of 
alphanumeric characters 

♦  DATA MATRIX (Numeric) – Select this type of Data Matrix 
barcode if the encoded is only numeric characters 

♦  DATA MATRIX (ASCII) – Select this type of Data Matrix 
barcode if the encoded data is a combination of 
alphanumeric and punctuation characters 

Note: Even though Data Matrix is a single barcode type, 
PCMate treats Data Matrix barcodes as three different 
types to help prevent you from truncating characters.  
For each Data Matrix barcode, we recommend you test 
your data for truncation issues before f inalizing your 
label design.  PCMate does not restr ict the input of 
character type based on the Data Matrix barcode type 
you select. 

Color ♦  Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

None This feature is not available for the any printer model.  

Expansion/ 
Narrow Bar 

♦  640x  
♦  6x6 
♦  Laser 
♦  SNAP 

PCMate does not support independent row and column 
expansion for Data Matrix barcodes, only single expansion of 
both row and column.  If you want to amplify the bar code 
image to enhance readability, set the number of dots that 
should be used to make the smallest cell in the barcode.  
Note: The value you enter here affects the Height  and Width  

of the barcode, but does not change the barcode 
symbol size you select from the 2D Features l ist box 
or the maximum number of characters shown in the 
Length  text box. 
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Properties Applicable 
Printers 

Description 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

All printers Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text All printers You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Height ( in/mm) All printers This read-only f ield shows the height of the barcode on the 
label design either in inches or mill imeters depending on the 
ruler that shows your label design orientation.  The value 
shown is based on the barcode symbol size you select from 
the 2D Features l ist box as well as the value you set for the 
Expansion/Narrow Bar. 

Inverse ♦  98xx 
♦  6x6 
♦  SNAP 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length All printers This read-only f ield shows the maximum number of 
characters that can be encoded in the barcode and is based 
on the barcode symbol size you select from the 2D Features 
l ist box, as well as the actual alphanumeric text input. 

Print Station All printers Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt All printers Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation All printers Select the orientation of the barcode on the label design 

Width (in/mm) All printers This read-only f ield shows the width of the barcode on the 
label design either in inches or mill imeters depending on the 
ruler that shows your label design orientation.  The value 
shown is based on the barcode symbol size you select from 
the 2D Features l ist box as well as the value you set for the 
Expansion/Narrow Bar. 
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A b o u t  M a x i C o d e  B a r c o d e s  
A MaxiCode barcode appears as a 1-inch square, with a bullseye in 
the middle, surrounded by a pattern of hexagonal dots.  It can store 
a maximum of 93 characters of data, and up to 8 MaxiCode 
symbols can be chained together to convey more data.  
 
 
 
The table below provides a description of the properties you can 
configure for a MaxiCode barcode.   
 
Properties Applicable 

Printers 
Description 

2D Features 98xx Select the encoding method for the barcode as follows: 
♦  Mode 0 (Obsolete) – Select this mode if the f irmware on 

your printer is outdated.  The two horizontal hexagons in 
the upper r ight-hand corner appear white.  For all other 
modes, they are black. 

♦  Mode 2 (Numeric) – Select this mode if you plan to use 
formatted data containing a structured Carrier Message 
with a numeric postal code. 

♦  Mode 3 (Alpha) – Select this mode if you plan to use 
formatted data containing a structured Carrier Message 
with an alphanumeric postal code.  

♦  Mode 8 (Auto) – Select this mode if you want the printer to 
auto-detect which encoding to use based on the text input.  

Barcode Type ♦  98xx 
♦  Laser 

Select MAXICODE. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Download 
Barcode as 
Graphic 

♦  98xx 
♦  Laser 

If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

Laser If you want to amplify the barcode image to enhance 
readability, set the number of dots that should be used to 
make the smallest cell in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

♦  98xx 
♦  Laser 

Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text ♦  98xx 
♦  Laser 

You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font Laser Laser printers use a default font. 
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Properties Applicable 
Printers 

Description 

HRI Posit ion Laser If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  
PCMate always prints the text at the bottom (underneath) the 
barcode. 

Inverse 98xx If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length ♦  98xx 
♦  Laser 

Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size Laser If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station ♦  98xx 
♦  Laser 

Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt ♦  98xx 
♦  Laser 

Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation ♦  98xx 
♦  Laser 

Select the orientation of the barcode on the label design 

Show HRI Laser If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

 

A b o u t  P D F 4 1 7  B a r c o d e s  
A PDF417 barcode is a stacked linear barcode 
symbol format.  The 417 signifies that each 
pattern in the code consists of 4 bars and 
spaces, and that each pattern is 17 units long.  
 
The table below provides a description of the 
properties for a PDF417 barcode. 
 

Properties Applicable 
Printers 

Description 

2D Features 98xx Select the ratio of cell width to cell height, which results in 
whether the barcode appears as a square or rectangle. 

Barcode Type ♦  98xx 
♦  Laser 

Select PDF 417. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

5-26  Label Design Guide   



Properties Applicable 
Printers 

Description 

Download 
Barcode as 
Graphic 

♦  98xx 
♦  Laser 

If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 

Expansion/ 
Narrow Bar 

Laser If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest cell in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

♦  98xx 
♦  Laser 

Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text ♦  98xx 
♦  Laser 

You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font Laser This option is not used. 

Inverse 98xx If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length ♦  98xx 
♦  Laser 

Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size Laser This option is not used. 

Print Station ♦  98xx 
♦  Laser 

Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt ♦  98xx 
♦  Laser 

Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation ♦  98xx 
♦  Laser 

Select the orientation of the barcode on the label design 

Row/Column 
Maximum Value 

♦  98xx 
♦  Laser 

Set the maximum number of characters allowed per 
row/column. 

Security Value ♦  98xx 
♦  Laser 

Select the level of sophistication in error correction and 
recovery.  The higher the security value, the larger the 
barcode. 

Truncate ♦  98xx 
♦  Laser 

If you want to produce a truncated PDF417 barcode that 
removes the r ight hand side of the barcode symbol, select 
this checkbox. 
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A b o u t  Q R  B a r c o d e s  
A Quick Response (QR) code is a two-dimensional barcode 
that consists of black modules arranged in a square pattern 
on a white background.  The information encoded can be 
made up of four standardized kinds (or modes) of data, 
including alpha, numeric, byte/binary, Kanji).  All QR codes 
must adhere to ISO standard 18004:2006.  
 
 
 
 
 
The table below provides a description of the properties for a QR code. 
 
Properties Applicable 

Printers 
Description 

Barcode Type ♦  SNAP  
♦  6x6 
♦  98xx 
♦  Laser 

Select QR. 

Color Laser If you are creating a label design and the target printer is a 
Xerox Laser, select the color of the barcode as it should 
appear on the printed labels. 

Error Correction ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select the error correction method for the QR code as 
follows: 
♦  L-High Density – Approximately 7% of codewords can be 

restored 
♦  M-Standard – Approximately 15% of codewords can be 

restored 
♦  Q-High Reliabil ity – Approximately 25% of codewords can 

be restored 
♦  H-Ultra High Reliabil ity – Approximately 30% of codewords 

can be restored 
Note: Codewords are 8 bits long.  The higher the error 

correction level, the less storage capacity.  

Expansion/ 
Narrow Bar 

♦  SNAP 
♦  6x6 
♦  98xx 

If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest cell in the barcode.  
Note: The value you enter here affects the Height  and Width  

of the QR code, but does not change the overall 
dimensions of the QR code you select from the 
Version  list box or the maximum number of characters 
shown in the Length text box. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 
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Properties Applicable 
Printers 

Description 

Fixed Text ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Height ( in/mm) ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

This read-only f ield shows the height of the QR code on the 
label design either in inches or mill imeters depending on the 
ruler that shows your label design orientation.  The value 
shown is based on the overall dimensions for the QR code 
symbol you select from the Version  list box as well as the 
value you set for the Expansion/Narrow Bar. 

Length ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

This read-only f ield shows the maximum number of 
characters that can be encoded in the QR code.  It is based 
on the mode (input character set) you select from the QR 
Type list box, the overall dimensions for the QR code symbol 
you select from the Version  l ist box, and error correction 
method you select from the Error Correction l ist box.  

Print Station ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select the part of the label design on which you want the QR 
code to print.  For more information about print stations, see 
Chapter 2, “About Label Designs.” 

Prompt ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing. If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select the orientation of the barcode on the label design 

QR Type ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select the mode (input character set) for the QR code as 
follows: 
♦  Numeric – 10 bits per 3 digits 
♦  Alphanumeric – 11 bits per 2 characters 
♦  Binary – 8 bits per character; must use only 1 and 0  
Note: Only Binary QR codes are supported with Xerox Laser 

printers. 

Version ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 

Select the overall dimensions for the QR code symbol. 

Width (in/mm) ♦  SNAP 
♦  6x6 
♦  98xx 
♦  Laser 
 

This read-only f ield shows the width of the QR code on the 
label design either in inches or mill imeters depending on the 
ruler that shows your label design orientation.  The value 
shown is based on the overall dimensions for the QR code 
symbol you select from the Version  list box as well as the 
value you set for the Expansion/Narrow Bar. 
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A b o u t  C u s t o m  B a r c o d e s  
PCMate supports two custom barcodes, including: 
♦ PUMA Code 128 
♦ SEARS Code 39 
The table below provides a description of the properties for a PUMA Code 128 barcode. 
 
Properties Applicable 

Printers 
Description 

Barcode Type ♦  SNAP 
♦  640x 
♦  6x6 

Select PUMA CODE 128. 

Download 
Barcode as 
Graphic 

♦  SNAP 
♦  640x 
♦  6x6 

If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 
Note: For 640x printers, you must download the barcode as a 

graphic image to the printer with other print job 
information. 

Expansion/ 
Narrow Bar 

♦  SNAP 
♦  640x 
♦  6x6 

If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

♦  SNAP 
♦  640x 
♦  6x6 

Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 

Fixed Text ♦  SNAP 
♦  640x 
♦  6x6 

You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font ♦  SNAP 
♦  640x 
♦  6x6 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 

Height ( in/mm) ♦  SNAP 
♦  640x 
♦  6x6 

Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion ♦  SNAP 
♦  640x 
♦  6x6 

If you select the Show HRI checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, for Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 

Inverse ♦  SNAP 
♦  640x 
♦  6x6 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length ♦  SNAP 
♦  640x 
♦  6x6 

Set the maximum number of characters that can be encoded 
in the barcode. 
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Properties Applicable 
Printers 

Description 

Point Size ♦  SNAP 
♦  640x 
♦  6x6 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station ♦  SNAP 
♦  640x 
♦  6x6 

Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt ♦  SNAP 
♦  640x 
♦  6x6 

Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation ♦  SNAP 
♦  640x 
♦  6x6 

Select the orientation of the barcode on the label design 

Show HRI ♦  SNAP 
♦  640x 
♦  6x6 

If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.  If 
you want PCMate to just print the barcode, clear this 
checkbox. 

Width (in/mm) ♦  SNAP 
♦  640x 
♦  6x6 

Set the maximum width of the barcode on the label design 
either in inches or mill imeters depending on the ruler that 
shows your label design orientation.  PCMate truncates any 
portion of the barcode extending beyond the width you enter.  
Warning: PCMate sets the width according to the barcode 

Expansion and Length .  If you decrease the 
width, you may lose barcode data.  

The table below provides a description of the properties for a SEARS Code 39 barcode.  
 
Properties Applicable 

Printers 
Description 

Barcode Type ♦  SNAP 
♦  6x6 

Select SEARS CODE 39. 

Download 
Barcode as 
Graphic 

♦  SNAP 
♦  6x6 

If you want to download the barcode as a graphic image to 
the printer with other print job information, select this 
checkbox.  If the barcode image is generated in the printer’s 
f irmware, clear this checkbox. 
Note: For 640x printers, you must download the barcode 

image to the printer with other print job information. 

Expansion/ 
Narrow Bar 

♦  SNAP 
♦  6x6 

If you want to amplify the bar code image to enhance 
readability, set the number of dots that should be used to 
make the smallest bar in the barcode. 

Field Posit ion ( in) 
♦  Width Offset 
♦  Length Offset 

♦  SNAP 
♦  6x6 

Set the absolute posit ion of the barcode object on the label 
design as follows:  
♦  Width Offset – Set the offset posit ion from the upper left-

hand corner of the web. 
♦  Length Offset – Set the offset posit ion from the upper left-

hand corner of the feed. 
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Properties Applicable 
Printers 

Description 

Fixed Text ♦  SNAP 
♦  6x6 

You can optionally enter static text to be encoded in the 
barcode and/or displayed as a human readable text in the 
label design.  This is usually left empty on the label design 
and populated from an auto- import, manual entry or ODBC 
library look up. 

Font ♦  SNAP 
♦  6x6 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the font you want for the text. 

Height ( in/mm) ♦  SNAP 
♦  6x6 

Set the height of the barcode on the label design either in 
inches or mill imeters depending on the ruler that shows your 
label design orientation. 

HRI Posit ion ♦  SNAP 
♦  6x6 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, For Xerox Laser printers, PCMate 
always prints the text at the bottom (underneath) the 
barcode.  For 640x, 6x6, and SNAP printers, you can select 
the top or the bottom. 

Inverse ♦  SNAP 
♦  6x6 

If you want PCMate to print a negative of the barcode, select 
this checkbox.  If you want PCMate to print a standard 
barcode, clear this checkbox. 

Length ♦  SNAP 
♦  6x6 

Set the maximum number of characters that can be encoded 
in the barcode. 

Point Size ♦  SNAP 
♦  6x6 

If you select the Show HRI  checkbox because you want 
PCMate to print human readable interpretation (HRI) of the 
data with the barcode, set the point size you want for the 
text. 

Print Station ♦  SNAP 
♦  6x6 

Select the part of the label design on which you want the 
barcode to print.  For more information about print stations, 
see Chapter 2, “About Label Designs.” 

Prompt ♦  SNAP 
♦  6x6 

Enter a unique name that identif ies the object on the label 
design.  The object name is the same as the f ield name that 
printer operators see when they open print jobs associated 
with the label design you are edit ing.  If you are going to 
populate the barcode object from an ODBC-compliant data 
source fi le, you may want to enter a name that is similar to 
the data in the data source fi le. 

Rotation ♦  SNAP 
♦  6x6 

Select the orientation of the barcode on the label design 

Ratio ♦  SNAP 
♦  6x6 

Select the narrow to wide bar ratio (the width from the narrow 
bar to the wide bar). 

Show HRI ♦  SNAP 
♦  6x6 

If you want PCMate to print human readable interpretation 
(HRI) of the data with the barcode, select this checkbox.   
If you want PCMate to just print the barcode, clear this 
checkbox. 
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W O R K I N G  W I T H  O B J E C T S  
Each label design has objects that are either placeholders for data or design 
elements that contribute to the overall design of the label.  Before you add an object to a 
label design, you need to know a little bit about the data intended for the object.  For 
example, if you add a text object to a label design, you need to know the maximum 
number of characters to determine the object size. 
In this chapter, you can how to 
♦ add objects. 
♦ edit object properties. 
♦ delete objects. 
♦ move objects. 
♦ cut, copy, and paste objects. 
♦ duplicate objects. 
♦ re-order objects. 
♦ align objects. 
♦ rotate objects. 
♦ justify object contents. 
♦ resize objects. 
♦ create objects by parsing data from other objects. 

A d d i n g  O b j e c t s  
Once you create a label design, you can add different types of objects to any side.  For 
information about the different types of objects you can add to a label design, see 
Chapter 4, “About Objects.” 

To Add an Object 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Either create or open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which you want to add the object. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. On the Object menu, click the type of object you want to add.  
Note:  You can also add objects from the toolbar as follows:  

 Text object 

 Barcode object 

 Rectangle/l ine object 

 Care symbol object 

 Picture object 

 Function f ield object 

  Data f ield object  
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6. In the Prompt text box, enter a name for the object.  
Note:  PCMate saves print jobs using the object names on each label design. At the 

time a print job is sent to the printer, PCMate merges the variable data with the 
latest label design by matching the object names between the print job and the 
latest design.  If PCMate has created a print job and you edit objects on the 
label design, be careful that you do not modify object names and cause a 
mismatch that results in missing data in the print job. 
In the Print Module, printer operators can open print jobs and see variable data 
within fields that may or may not be editable, depending on how you configure 
the label design.  The name you give an object is the field name the printer 
operators see when they open print jobs for data entry, sorting, and printing.  

7. Configure the remaining object properties. 
Note:  If you are creating a label design for the printer operator to manually input data 

from an ODBC-compliant data source, you may want to select the Create New 
Batch After Edit checkbox for PCMate to create a new batch each time after 
the printer operator performs a lookup.  If you also select the Next Field to 
Edit, PCMate places the cursor in the field of the new batch each time after a 
lookup.   
For more information about object properties, see Chapter 4, “About Objects.”  

8. Click OK. 

E d i t i n g  O b j e c t  P r o p e r t i e s  
Each object has properties that define how the object looks and behaves.  Once you add 
an object to a label design, you can edit the properties for the object.  However, you 
should not change the name of the object.  

To Edit the Properties for an Object 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. Click the object you want to edit 
6. On the Edit menu, click Properties. 

Note:  You can also double-click the object to see the object properties.  
7. Edit the object properties as needed. 

Note:  PCMate saves print jobs using the object names on each label design.  At the 
time a print job is sent to the printer, PCMate merges the variable data with the 
latest label design by matching the object names between the print job and the 
latest design.  If PCMate has created a print job and you edit objects on the 
label design, be careful that you do not modify object names and cause a 
mismatch that results in missing data in the print job. 
For more information about object properties, see Chapter 4, “About Objects.”  

8. Click OK. 
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D e l e t i n g  O b j e c t s  
At any time, you can delete an object from a label design.  When you delete an object, 
you permanently remove the object and its properties from PCMate.  

To Delete an Object 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. Select the object or objects you want to delete. 
Note:  To select an object, click the object.  To select multiple objects, press SHIFT 

while selecting each object.  You can also click a blank area within the label 
design, press SHIFT and drag your mouse over the objects you want to select. 
To select a non-print object, on the Edit menu, click Select Fields.  To select 
more than one non-print object, press and hold the SHIFT key while clicking 
the each object.  After your objects are selected, click OK. 

6. On the Edit menu, click Delete. 

Note:  You can also press the DELETE key on your keyboard, or click  on the 
toolbar. 

7. When asked whether you want to delete the object, click Yes. 
8. Click OK. 

M o v i n g  O b j e c t s   
You can edit the properties for any object and set the 
exact position of the object on the label design.  The 
figure on the right shows object coordinates that can be 
set for each object. 
When moving objects, it is important to remember the 
length represents the feed direction.  Therefore, the 
Length Offset moves the object right or left.  The Width Offset moves the object up or 
down.  For more information about setting the exact position of an object, see “Editing 
Object Properties” in this chapter. 
You can also move objects without editing the object properties.  The procedures for 
moving objects differ depending on whether you want to move an object on the same side 
of label, or if you want to move an object to a different side of the label.  If you want to 
move an object to another label design altogether, see “Cutting, Copying, and Pasting 
Objects” in this chapter. 

To Move an Object on the Same Label Side 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Create or open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object(s) resides.  
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 
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5. Select the object or objects you want to move. 
Note:  To select an object, click the object.  To select multiple objects, press SHIFT 

while selecting each object.  You can also click a blank area within the label 
design, press SHIFT and drag your mouse over the objects you want to select. 
To select a non-print object, on the Edit menu, click Select Fields.  To select 
more than one non-print object, press and hold the SHIFT key while clicking 
the each object.  After your objects are selected, click OK. 

6. Either use the keyboard or your mouse to move the object(s). 
Note:  To use the keyboard, press CTRL+M+the arrow key of the direction in which 

you want to move the object(s).  To use the mouse, press and hold CTRL while 
clicking and moving the object(s).  Release the CTRL key and mouse button 
when you are satisfied with the location of the object(s). 

7. Click OK. 

To Move an Object to another Side of the Label 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. Select the object you want to move. 
Note:  To select an object, click the object.  To select a non-print object, on the Edit 

menu and then click Select Fields.  Click the object and then click OK.  
6. On the Edit menu, click Properties. 
7. From the Print Station list box, select the print station for the side of the label on 

which you want to move the object.  
Note:  The location of the Print Station list box may be on different tabs depending 

on the type of the object you are moving. 
8. Click OK. 

C u t t i n g ,  C o p y i n g ,  a n d  P a s t i n g  O b j e c t s   
When you cut an object, you remove the object from its current position and place the 
object on your clipboard.  When you copy an object, you keep the object in its current 
position and place a copy of the object on your clipboard.  Objects remain on the 
clipboard (your PC memory) until you either cut or copy another object.  When you paste 
an object, you place the object on the label design.  PCMate retains all object properties 
when you cut, copy, and paste objects.  

To Copy and Paste an Object 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 
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5. Select the object or objects you want to copy. 
Note:  To select an object, click the object.  To select multiple objects, press SHIFT 

while selecting each object.  You can also click a blank area within the label 
design, press SHIFT and drag your mouse over the objects you want to select. 
To select a non-print object, on the Edit menu, click Select Fields.  To select 
more than one non-print object, press and hold the SHIFT key while clicking 
the each object.  After your objects are selected, click OK. 

6. On the Edit menu, click Copy Fields. 
Note:  To remove the selected object(s) from your label design, but copy the object(s) 

to your clipboard so that you can place them somewhere different, click Cut 
Field(s) instead. 

7. Click OK. 
8. Navigate to where you want to paste the object(s) on your clipboard. 

Note:  You can paste the objects on the same side of the current label design, on a 
different side of the label design, or on a new label design altogether.  

9. On the File menu, click Paste Fields. 

D u p l i c a t i n g  O b j e c t s  
If you want to place one or more copies of an object on the same side of the label design, 
you can duplicate the object.  When you duplicate an object the position of the new 
object(s) is offset from the current object one printer increment in the web and feed 
directions.  

To Duplicate an Object  
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Create or open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. Select the object you want to duplicate. 
Note:  You can only duplicate one object at a time. 

6. On the Edit menu, click Duplicate.  
7. When prompted, enter the number of duplicate objects you want to create.  
8. Click OK.  
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R e - o r d e r i n g  O b j e c t s  
Object order is very important to help printer 
operators interpret data in open print jobs.  If you are 
using macros and/or ODBC-compliant data source 
files to input data, object order becomes critical.  
PCMate builds a list of objects in the order you add 
them to a label design.  The order of the objects from 
top to bottom represents the fields that printer 
operators see from left to right in an open print job. 
As illustrated in the figure, PCMate automatically 
adds to objects to each label design you create – 
Quantity and Download.  Because PCMate adds 
these objects automatically, they are at the top of the 
list and are the first two fields a printer operator sees 
when opening a print job.  All other objects you add 
to the label design appear in the list in the order you 
add them.  However, you can change the order at any 
time.   

To Re-order Objects on a Label 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Create or open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the objects reside. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. On the Edit menu, click Order.  
6. Click the first object you want to move and then drag and drop the object in the new 

position. 
7. When all of the objects are placed in the correct order, click OK.  

Note:  PCMate saves print jobs using the object names on each label design.  At the 
time a print job is sent to the printer, PCMate merges the variable data with the 
latest label design by matching the object names between the print job and the 
latest design.  If PCMate has created a print job and you edit objects on the 
label design, be careful that you do not modify object names and cause a 
mismatch that results in missing data in the print job. 
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A l i g n i n g  O b j e c t s  
You should not place objects arbitrarily.  The concept of alignment says that everything 
on a label design should be visually connected to something else on the label design.  
Alignment creates a sharper, more ordered design.  When you align objects, they are 
visually connected to each other, even if they are separated on the label.  Alignment 
tightens the design and eliminates the haphazard, messy effect which occurs when 
objects are placed randomly. 
The table below provides a list of the options you have to align objects on the same side 
of a label design. 
 
Option Description 

Space Fields Equally Equalizes the vertical spacing between selected objects  

Increase Line Spacing Increases the vertical spacing among selected objects (makes them 
further apart) 

Decrease Line Spacing Decreases the vertical spacing among selected objects (makes them 
closer) 

Left Align Field Left aligns selected objects 

Center Align Field Uses the widest object selected to center align selected objects 

Right Align Field Right alights selected objects 
 
As illustrated in the figure, PCMate creates a selection box when you select multiple 
objects.  

  
The selection box is the length of all the objects selected and the width of the widest 
object selected.  PCMate uses the dimensions of the selection box to adjust the vertical 
and/or horizontal alignment of the selected objects. 

To Align a Group of Objects  
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object(s) resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 
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5. Select the objects you want to align. 
Note:  To select an object, click the object.  To select multiple objects, press SHIFT 

while selecting each object.  You can also click a blank area within the label 
design, press SHIFT and drag your mouse over the objects you want to select.  
To select a non-print object, on the Edit menu, click Select Fields.  To select 
more than one non-print object, press and hold the SHIFT key while clicking 
the each object.  After your objects are selected, click OK. 
PCMate uses the dimensions of the selection box to adjust the vertical and/or 
horizontal alignment of the selected objects. 

6. On the Edit menu, click Align And then click the alignment option you want to use. 
Note:  For a description of alignment options, see “Aligning Objects” in this chapter. 

7. Click anywhere outside the selection box to deselect the group of objects. 

R o t a t i n g  O b j e c t s  
As illustrated in the figure, you can edit the properties for any 
object and set the rotation of the object on the label design to 0 
degrees, 90 degrees, 180 degrees, or 270 degrees.  
For more information about setting the rotation of an object, see “Editing Object 
Properties” in this chapter. 
You can also rotate one or more objects without editing the object properties. 

To Rotate an Object  
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Create or open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object(s) resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. Select the object or objects you want to rotate. 
Note:  To select an object, click the object.  To select multiple objects, press SHIFT 

while selecting each object.  You can also click a blank area within the label 
design, press SHIFT and drag your mouse over the objects you want to select. 
To select a non-print object, on the Edit menu, click Select Fields.  To select 
more than one non-print object, press and hold the SHIFT key while clicking 
the each object.  After your objects are selected, click OK. 

6. On the Edit menu, click Rotate Left to rotate the object(s) 90 degrees 
counterclockwise or click Rotate Right to rotate the objects 90 degrees clockwise. 

7. If you selected multiple objects, click anywhere outside the selection box to deselect 
the group of objects. 
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J u s t i f y i n g  O b j e c t  C o n t e n t s   
As illustrated in the figure, you can edit the properties for a text 
object, care symbol object, picture object, and function object 
and set the horizontal justif ication for its contents to Align Left, 
Align Center, Align Right, or Align As Is.  For a picture object, you can also set the 
vertical and horizontal alignment.   
For more information about setting the rotation of an object, see “Editing Object 
Properties” in this chapter. 
You can also adjust one or more objects without editing the object properties.  

To Justify the Contents for an Object  
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object(s) resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. Select the object or objects for which you want to justify the contents. 
Note:  To select an object, click the object.  To select multiple objects, press SHIFT 

while selecting each object.  You can also click a blank area within the label 
design, press SHIFT and drag your mouse over the objects you want to select. 
To select a non-print object, on the Edit menu, click Select Fields.  To select 
more than one non-print object, press and hold the SHIFT key while clicking 
the each object.  After your objects are selected, click OK. 

6. On the Edit menu, click Left Justify Text to left align the object contents.  Click 
Center Justify Text to center align the object contents or click Right Justify Text to 
right align the object contents.  

7. If you selected multiple objects, click anywhere outside the selection box to deselect 
the group of objects. 

R e s i z i n g  O b j e c t s  
You can adjust the size of an object without editing the object properties.  

To Resize an Object  
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Open a label design. 
4. On the View menu, click Side and then click the print station for the part of the label 

on which the object resides. 
Note:  For information about print stations, see Chapter 2, “About Label Designs.” 

5. Click the object you want to resize. 
6. On the Edit menu, click Size. 
7. When the black box appears, use the up and down arrow keys on your keyboard to 

adjust the size. 
8. Press ENTER. 
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C r e a t i n g  O b j e c t s  b y  P a r s i n g  D a t a  f r o m  O t h e r  O b j e c t s  
You can create data for a target object using data from other source objects.  To illustrate 
this, we created an example scenario where you create data for a target object by using 
data from two text objects and one barcode object.  

EXAMPLE: To Create an Object by Parsing Data from Other Objects 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Either create or open a label design. 
4. On the View menu, click Side and then click the side of the label design to which you 

want to add the object. 
Note:  For information about print stations, see Chapter 4, “About Objects.” 

5. Add two text objects to the label design.  Name the first object Short, and set the 
Length to 5.  Name the second object Long, and set the Length to 10. 

6. Add a Code 128 barcode object to the label design, and set the length to 15. 
7. Edit the properties for the barcode object you added to the label design. 
8. Click the Substring tab. 
9. From the Field List list box, select Short. 
10. From the Start Character Position list box, select 1. 
11. From the Number of Characters to Copy l ist box, select 5. 
12. Click Add. 
13. From the Field List list box, select Long. 
14. From the Start Character Position list box, select 1. 
15. From the Number of Characters to Copy l ist box, select 10. 
16. Click Add. 
17. Click OK. 

Note:  PCMate saves print jobs using the object names on each label design.  At the 
time a print job is sent to the printer, PCMate then merges the variable data 
with the latest label design by matching the object names between the print job 
and the latest design.  If PCMate has created a print job and you edit objects 
on the label design, be careful that you do not modify object names and cause 
a mismatch that results in missing data in the print job. 
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W O R K I N G  W I T H  T H E  A U T O - I M P O R T  
R O U T I N E  
The Auto-Import Routine is an automated process that imports new label designs, as well 
as imports and creates print jobs by merging variable data files with label designs.  
PCMate runs the Auto-Import Routine each time you open the software.  Also, printer 

operators can run the Auto-Import Routine manually by clicking  on the toolbar.  You 
can configure PCMate to run in Auto-Print Mode where PCMate runs in the background, 
automatically importing and sending batches to the printer as new print jobs become 
available.  
In this chapter, you can learn how to 
♦ configure label design import settings for the Auto-Import Routine. 
♦ prepare variable data files for print jobs. 
♦ create auto-import maps for print jobs. 
♦ edit the properties of auto-import maps for print jobs. 
♦ disable and enable auto-import maps for print jobs. 
♦ run the Auto-Import Routine for specific auto-import maps for print jobs. 
♦ delete auto import maps for print jobs. 

C o n f i g u r e  L a b e l  D e s i g n  I m p o r t  S e t t i n g s  f o r  t h e  A u t o - I m p o r t  R o u t i n e  
When the Auto-Import Routine runs, PCMate 
always imports label designs first, then 
imports and creates print jobs with the latest 
label designs.  For the Auto-Import Routine to 
import label designs, you must set the 
location where PCMate should look for .ZIP 
files that contain label design files, including: 
tag background images, auto-import maps, 
and log sets.  
The figure on the right illustrates the options 
you can configure for the Auto-Import 
Routine.  By default, the location where 
PCMate looks for label designs to import is: 
C:\Paxarwin\A_UPDATE 

If you are obtaining label designs from the 
Avery Dennison Web Services Portal, do not 
change this location.  However, if you are 
creating your own label designs, you can 
change the location if needed. 
PCMate imports label design files to the 
appropriate folders within your default 
working folder. 
For information about how to set the default 
working folder, refer to Chapter 3, 
“Configuring Your Software” in the 
PCMate’s Label Printing Guide. 
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The table below provides a description of the options you can configure for the Auto-
Import Routine.  
 
Option Description 

Enable design auto 
imports 

If you select this checkbox, the Auto-Import Routine looks in this 
location for .ZIP fi les with new label designs to import. If you clear this 
checkbox, the Auto-Import Routine sti ll  runs, but does not import label 
designs when executed.  Instead, PCMate only creates print jobs when 
the Auto-Import Routine runs.  You can sti l l manually import label 
designs when needed.  For information about how to import label 
designs, see Chapter 3, “Working with Label Designs.” 

Overwrite Existing 
Designs on Import 

If you select this checkbox, PCMate imports .ZIP fi les and overwrites 
existing label designs that have the same name and belong to the same 
design set.  If you clear this checkbox, PCMate does not import.ZIP fi les 
that contain duplicate label design.  The .ZIP f i les remain in the import 
folder until you either delete the .ZIP fi le or delete the existing label 
design and rerun the Auto-Import Routine. 

To Configure Label Design Import Settings for the Auto-Import Routine  
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. On the Tools menu, click Auto Import Designs Setup. 
4. Configure the label design import settings as needed. 

Note:  If you want to change the location where PCMate looks for .ZIP files, select the 
directory from the list box and then click [..] to see the folders on the directory.  
Continue clicking through the folders until you get to the folder you want 
PCMate to look in for .ZIP files. 

5. Click OK. 

P r e p a r i n g  V a r i a b l e  D a t a  F i l e s  f o r  P r i n t  J o b s  
Only flat ASCII Code Page 850 or Unicode text f iles are compatible with the Auto-Import 
Routine in the following manner: 
♦ The file contents must include only batch data with no headers. 
♦ The file can include fixed length records or data separators and delimiters, if needed. 
If you are using the Avery Dennison Web Services Portal to download flat print job files, 
the Portal places your variable data files in the following working folders: 
C:\D2Comm\[DESIGN SET NAME]\Batch\[JOB FILE NAME] 

If you are creating your own print jobs, you can save your variable data files in any 
location that is accessible from your PCMate workstation. 
When you create an auto-import map for a label design, you link the label design with a 
variable data file, or with multiple variable data files that have the same naming 
convention and reside in the same location.  If you move the location of your variable 
data files, you must update any auto-import maps you created. 
By default, the name of your variable data files determines the name of the print jobs 
created by the Auto-Import Routine.  However, you can change the way PCMate names 
the print jobs for each auto-import map you create.  For information about how you want 
PCMate to name your print jobs, see “Creating Auto-Import Maps for Print Jobs” later in 
this chapter. 
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If you want to create multiple labels (for example, multiple-piece item, such as a two-
piece jogging suit) from a single variable data file, you can create an auto-import map for 
each label design and point to the exact same file name in the same location.  Then you 
can create one variable data file, and PCMate creates two print jobs: one for each label 
design. 
If you decide to place all of your variable data files in the same location, use a naming 
convention to isolate what variable data files go with which label designs.  You can name 
variable data files with information pertinent to your business and add a unique file 
extension to determine which label design to use.  For example, job11111.001 or 
job22222.002.  Then, when you create your import maps, you can use a wild card for the 
Import Path.  For example, C:\TEMP\*.001 for one label design and C:\TEMP\*.002 for a 
second label design.  When executed, the Auto-Import Routine creates a print job using 
the proper label design for any file placed in the C:\TEMP folder ending with .001 or .002. 

C r e a t i n g  A u t o - I m p o r t  M a p s  f o r  P r i n t  J o b s  
The Auto-Import Routine creates print jobs only for 
label designs that have import maps.  If a label 
design is attached to an external data source, such 
as an ODBC-compliant source file, the Auto-Import 
Routine looks up the supplemental data after the 
import map is executed, but before creating and 
saving the print job. 
An auto-import map links a label design with a 
variable data file, or with multiple variable data 
files that have the same naming convention and 
reside in the same location.  
Each auto-import map is unique to a label design 
and an import path.  The import path specifies the 
location and file name, or f ile naming conventions, 
for the associated variable data file(s). 
If you need to link a single label design to multiple 
variable data files that reside in different locations, 
you can create multiple auto-import maps for the 
same label design.  
If you have a variable data file that contains data 
for multiple label designs, you can create an auto-import map and link each label design 
to the same variable data file.  For example, from a single variable data file, you can 
create a price ticket, a care label, a size sticker and a carton label as long as all the 
required data is in the file and you have a label design for each label you want to create. 
You cannot create an import map for a label design that is password protected unless you 
know the password. 
As illustrated in the figure, each auto-import map has options you can configure for Auto-
Print Mode.  

Auto-Print Mode is where PCMate runs in the background, automatically importing and 
sending batches to the printer as new print jobs become available.  
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The table below provides a description of the options you can configure for Auto-Print 
Mode. 
 
Option Description 

Enable Auto Print 
Mode 

If you select this checkbox, each time PCMate creates a print job using 
the label design and variable data f ile(s) def ined on the auto-import 
map, PCMate immediately sends the new print job to the last COMM 
port that was used.  If you clear this checkbox, each time PCMate 
creates a print job using the label design and variable data f i le(s) 
defined on the auto-import map, PCMate places the print job in the Job 
Manager. 

Override Default 
Printer 

In Auto-Print Mode, PCMate sends print jobs to the last COMM port that 
was used.  If you select this checkbox, PCMate can either use the name 
of the variable data f i le to determine the numerical COMM port for the 
printer to which the print jobs should be sent, or you can specify the 
actual printer name.  If you select this checkbox, you must select an 
Override Source . 

Override Source If you select the Override Default Printer  checkbox, you must specify 
how you want PCMate to determine the printer COMM port that should 
be used each time PCMate creates a print job using the label design 
and variable data f i le(s) defined on the auto- import map.  If you select 
File Name or Extension, you must specify the Offset.  If you select 
Printer Name,  you must enter the Printer Name. 

Offset If you select the Override Default Printer  checkbox and select File 
Name or Extension as the Override Source , you must specify which 
character to use in the f ile name/extension to serve as the COMM port.  

Printer Name If you select the Override Default Printer  checkbox and select Printer 
Name as the Override Source, you must specify the name of the 
printer. 

 
As illustrated in figures below, when you create an auto-import map for a label design, 
you must map each field/object name in the label design to a data position within a flat 
text variable data file.  You do not have to map every object on a label design to data in 
the variable data file, only the desired objects. 
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The table below provides a description of the options you can configure when mapping 
the import for the label design to the variable data file.  
 
Option Description 

Include Batch Name 
in Field List 

PCMate automatically names the print job the same as the f i le name.  
However, you can override this naming convention. 
If you select this checkbox, PCMate adds another object to the Design 
Field List  called [Batch Name].  Map this object to the desired print job 
name in the variable data f ile. 

Separator If the variable data f i le is a f ixed length record, select None.  Otherwise, 
select the separator used in the variable data f i le. 

Delimiter If a delimiter is used, select the delimiter.  Otherwise, select None. 

File Posit ion If the variable data f i le uses a separator, select the posit ion of the data 
that should be imported in the object selected in the Design Field List . 

Field Offset If the variable data f i le is a f ixed length record, select the starting 
character location of the data that should be imported in the object 
selected in the Design Field List . 
Note: To ignore any data in the input f i le, set the Field Offset to 0. 

Field Length If the variable data f i le is a f ixed length record, select the number of 
characters that should be imported in the object selected in the Design 
Field List.  
Note: PCMate only imports the number of characters that f it  within the 

Length specif ied for the object.  If you import more characters 
than the object length, you may lose data during the import.  

Value from File This is a read-only f ield. 

Delete Files After 
Import 

If you select this checkbox, the Auto-Import Routine deletes the variable 
data f i le after creating the print job.  If you clear this checkbox, the 
Auto-Import Routine does not delete the variable data f ile in which case 
PCMate creates another print job the next t ime the Auto-Import Routine 
runs. 

To Create an Auto-Import Map for a Label Design 
1. Place the variable data file in the directory location from where you plan to import data 

each time the Auto-Import Routine runs.  
2. Place any logo files in the following default working folder:  

C:\Paxarwin\logos 
3. Install any new fonts, or place if the fonts are available as a printer resident font, 

place the fonts in the following default working folder:  
C:\Paxarwin\fonts 

4. Open PCMate, and log on if required. 
5. On the Window menu, click Print Module. 

Note:  If you are already in the Print Module, make sure the Job Manager is closed. 
6. On the File menu, click Import External Files. 
7. From the Design Set list box, select the design set to which the label design belongs. 
8. From the Design l ist box, select the label design. 
9. For Import Type, click Text. 
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10. For Import Path, click Browse and then navigate to the directory location from where 
you plan to import variable data each time the Auto-Import Routine runs.  Click the 
variable data file and then click Open. 
Note:  If you want the Auto-Import Routine to create multiple print jobs from multiple 

variable data files, and each variable data file has the same file extension, 
specify the directory location.  Then enter a wild card with the file extension 
(for example, *.001).  When executed, the Auto-Import Routine creates a print 
job for any file placed in the directory location ending with the file extension 
you specify.  

11. If PCMate is running in Auto-Print Mode and you want PCMate to send print jobs 
created by the Auto-Import Routine directly to the printer, configure the Auto-Print 
Mode options. 
Note:  For more information about Auto-Print Mode options, see the table earlier in 

this chapter. 
12. If you want PCMate to overwrite any fixed data, select the Overwrite Precanned Data 

checkbox.  If you want PCMate keep any fixed data, clear the Overwrite Precanned 
Data checkbox. 

13. If you want PCMate to replace existing print jobs that have the same name with a new 
print job, select the Overwrite Existing Print Files checkbox.  If you want PCMate not 
to create print jobs if there is a print job with the same name, clear the Overwrite 
Existing Print Files checkbox. 

14. Click the Setup tab, and map each field/object on the label design to a position in the 
variable data file. 

15. Click Save. 
16. When prompted, enter a name for the import map. 
17. Click OK. 

E d i t i n g  t h e  P r o p e r t i e s  f o r  A u t o - I m p o r t  M a p s  
After you create an auto-import map, you can edit the properties as needed.  As shown in 
the figure below, in the Auto Import Manager you can manage your auto-import maps and 
manually execute the Auto-Import Routine using one or all of the auto-import maps that 
are enabled. 
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You cannot edit an import map for a label design that is password protected unless you 
know the password.  

To Edit the Properties for an Auto-Import Map 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Print Module. 

Note:  If you are already in the Print Module, make sure the Job Manager is closed. 
3. On the Tools menu, click Auto Import Manager. 
4. In the list, click the auto-import map you want to edit. 
5. Click Edit. 
6. Edit the auto-import map properties as needed. 

Note:  PCMate saves print jobs using the object names on each label design.  At the 
time a print job is sent to the printer, PCMate merges the variable data with the 
latest label design by matching the object names between the print job and the 
latest design.  If PCMate has created a print job and you edit objects on the 
label design, be careful that you do not modify object names and cause a 
mismatch that results in missing data in the print job. 

7. Click Save. 
Note:  If you want to create a new auto-import map with using the properties that are 

configured for the current auto-import map, click Save As.  When prompted, 
enter the name for the new auto-import map and then click Save. 

8. When prompted for the name of the auto-import map, click Save to keep the existing 
name for the auto-import map or enter a new name, and click Save to change the 
name of the auto-import map. 

D i s a b l i n g  a n d  E n a b l i n g  A u t o - I m p o r t  M a p s  
By default, each auto-import map you create is enabled and included when the Auto-
Import Routine runs.  If you want to temporarily exclude an auto-import map from the 
Auto-Import Routine, you can disable the auto-import map then enable the auto-import 
map as needed.  You cannot disable an import map for a label design that is password 
protected unless you know the password. 

To Disable and Enable an Auto-Import Map 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Print Module. 

Note:  If you are already in the Print Module, make sure the Job Manager is closed. 
3. On the Tools menu, click Auto Import Manager. 
4. In the list, click the auto-import map. 
5. Click Disable. 

Note:  When you disable an auto-import map, the asterisks (***) no longer appear 
before and after the file name.  

6. When you want to enable the auto-import map, repeat steps 1–4 and then click 
Enable. 
Note:  For each auto-import map that is enabled, an asterisks (***) appears before 

and after the file name. 

Working with the Auto-Import Routine   7-7   



R u n n i n g  t h e  A u t o - I m p o r t  R o u t i n e  f o r  S p e c i f i c  A u t o - I m p o r t  M a p s  
When the Auto-Import Routine is executed, PCMate uses import maps to look for new 
variable data files and create print jobs.  However, you can run the Auto-Import Routine 
for a specific auto-import map to see what your print job looks like. 

To Run the Auto-Import Routine for a Specific Auto-Import Map 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Print Module. 

Note:  If you are already in the Print Module, make sure the Job Manager is closed. 
3. On the Tools menu, click Auto Import Manager. 
4. In the list, click the auto-import map. 
5. Click Execute Selected. 
6. In the Import List dialog box, click OK. 

Note:  If a label design is attached to an external data source, such as an ODBC-
compliant source file, the Auto-Import Routine looks up the supplemental data 
while creating the print job. 

D e l e t i n g  A u t o - I m p o r t  M a p s  
At any time, you can delete an auto-import map for a label design.  You cannot delete an 
import map for a label design that is password protected unless you know the password. 

To Delete an Auto-Import Map 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Print Module. 

Note:  If you are already in the Print Module, make sure the Job Manager is closed. 
3. On the Tools menu, click Auto Import Manager. 
4. In the list, click the auto-import map. 
5. Click Delete. 
6. If prompted, enter the password for the label design and then click OK.  Otherwise, 

skip this step. 
7. When prompted to delete the auto-import map, click Yes. 
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W O R K I N G  W I T H  O D B C  L I B R A R Y  
L O O K U P S  
You can link label designs to Open DataBase Connectivity (ODBC) compliant data source 
files to perform lookups of variable data for print jobs.  Printer operators can manually 
perform lookups to input data.  PCMate has an Auto-Import Routine that, when executed 
either manually or in Auto-Print Mode, performs lookups from the ODBC-compliant data 
source file and creates a print job that has batches of variable data.  
In this chapter, you can learn about ODBC library lookups, as well as how to 
♦ prepare an ODBC-compliant data source file. 
♦ add the trigger object to label designs. 
♦ link label designs to ODBC-compliant data source files. 
♦ map objects on label designs to variable data in ODBC-compliant data source files. 

A b o u t  O D B C  L i b r a r y  L o o k u p s   
A label design is linked to an ODBC-compliant data source file for the purposes of 
inputting variable data into print jobs either manually or through the Auto-Import Routine.  
The table below provides a description of the three types of objects required for data 
lookups.  
 
Type Description 

Target objects In a print job, a target object becomes a target f ield in which PCMate 
populates data after performing a lookup.  A label design can have 
multiple target objects. 

Key objects In a print job, a key object becomes a key f ield in which the printer 
operator or the Auto-Import Routine inputs a text value that l inks to 
variable data required for one or more target f ields.  A label design can 
have multiple key f ields.  Also, a key f ield can be designated as a target 
f ield in which PCMate overwrites the key during the lookup. 

Trigger object In a print job, the tr igger objects becomes the trigger f ield that executes 
the data lookup – using key f ields to populate data in target f ields. 

A label design can include a combination of objects that do and do not require variable 
data from the data source file.  The order of the objects on a label design (from top to 
bottom) determines the position of the fields in an open print job (from left to right). 
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The figure below illustrates the order of objects on a label design.  

  
The figure below illustrates the order of f ields in a print job.  

 
For a single label design, there can be multiple key and target objects on any side of the 
label.  However, you can only have one trigger object.  To ensure that PCMate looks up 
the data for all key fields, the order of the trigger object should be positioned after all key 
objects (from left to right).  Otherwise, the lookup may miss key fields in the source file 
and return no values in the target objects. 
In the examples shown above, STYLE, COLOR, SIZE, and PRICE are all 6-character text 
objects and placed in that order.  BARCODE is a 12-character barcode object.  There is 
also a non-print text object named CODE that serves as the only key object and the one 
trigger object to lookup data in the source file.  
Once you create a label design, the printer operator needs know which fields are key 
fields, target f ields, and the trigger f ield.  PCMate does not look up the data until the 
printer operator or the Auto-Import Routine inputs text values in the key fields and 
perform the lookup using the trigger f ield.  
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P r e p a r i n g  O D B C - C o m p l i a n t  S o u r c e  F i l e s  
ODBC  is a standard database access method that makes it possible for PCMate to 
access any data from any application, regardless of which database management system 
is handling the data.  Some examples of common ODBC-compliant databases are: 
♦ Microsoft Excel  
♦ Microsoft Access 
♦ Microsoft SQL Server  
♦ Oracle  
♦ Microsoft Visual FoxPro 
♦ IBM DB2 
With PCMate, most companies use Microsoft Excel and Microsoft Access.  
If you are setting up Microsoft Excel 
data source file, the format for all cells 
must be TEXT.  In addition, the first 
row in the spreadsheet must be the 
HEADER for all other information.  The 
headers you enter here become field 
names that printer operators use to 
input and interpret variable data in their 
print jobs.  All rows that follow the 
header row become a record that is 
imported.  
Records become batches that printer 
operators use to organize and manage 
their print jobs.  Each row/batch can 
have one or more key lookup fields, 
and the data value for each key field 
should be unique.    
PCMate can only link to one sheet (tab) 
in Microsoft Excel workbook.  
If your data is on several sheets, you 
must link the sheets in your Microsoft 
Excel f ile.  
In the same way, PCMate can only link to one database table in Microsoft Access 
database.  If your data is in several tables, you must link the tables in your Microsoft 
Access database. 
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Objects on a label design become fields in a print job.  The object/f ield name does not 
have to match the header/field name in the data source file.  However, it would help when 
you mapping objects to variable data. 
For the data source file itself, there are no file naming restrictions.  You can save the 
data source file in any directory location that is accessible from your PCMate workstation.  
PCMate preserves ODBC links to data source files during the label design export and 
import processes. 

A d d i n g  t h e  T r i g g e r  O b j e c t  t o  L a b e l  D e s i g n s  
The first step in creating a label design that is attached to an ODBC-compliant data 
source file is to designate which object on the label design is the trigger object.  When 
you map objects to variable data in an ODBC-compliant data source file, you must also 
specify the trigger object, along with the key and target objects.  For information about 
how to map objects to variable data, see “Mapping Objects to Variable Data” in this 
chapter. 
The order of the objects on a label design determines the position of the fields in an open 
print job.  If you add multiple key objects to a label design, make sure the trigger object 
appears after all key objects so that when PCMate performs the lookup, it retrieves data 
for all key fields.  For information about how to re-order objects on a label design, see 
Chapter 6, “Working with Objects.” 

To Add the Trigger Object to a Label Design  
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Create or open a label design.  
4. On the Object menu, click the type of object you want to add. 

Note:  If you add multiple key objects to the label design, make sure the trigger object 
appears after all key objects so that when PCMate performs the lookup, it 
retrieves data for all key fields.   
For information about how to re-order objects on a label design, see Chapter 6, 
“Working with Objects.” 
With the exception of rectangle/line objects, you can map all types of objects, 
both print and non-print, to variable data in an ODBC-compliant source file. 

5. In the Properties dialog box, click the Field Tag tab. 
6. In the Library frame, select the Trigger Lookup checkbox.  

Note:  An object can be both a key object and the trigger object.  When you map 
objects to variable data in the ODBC-compliant data source file, you must 
specify the trigger object again, along with the objects that are key and target 
objects. 

7. In the Field Security frame, select the Display/Editable Field checkbox. 
Note:  If you are adding a non-print object, you should select the Display/Editable 

Field checkbox so that the printer operator can see the field when he/she 
opens a print job.  Selecting this checkbox only makes the field viewable in an 
open print job and not on your label design. 
If you are adding a print object, you may want to select the Editable Only 
Before Library Lookup checkbox and set the Editable by User Level f ield to 
3 to prevent the printer operator from editing the field in an open print job.  

8. On the File menu, click Save. 
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L i n k i n g  L a b e l  D e s i g n s  t o  O D B C -  C o m p l i a n t  D a t a  S o u r c e  F i l e s  
After you add objects to your label design and designate which object is the trigger 
object, the next step is to link the label design to the ODBC-compliant data source file.  

To Link a Label Design to an ODBC-Compliant Data Source File 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module.  
3. Open the label design. 
4. Add the objects, and specify the trigger object on the label design. 

Note:  If you add multiple key objects to the label design, make sure the trigger object 
appears after all key objects so that when PCMate performs the lookup, it 
retrieves data for all key fields.  For information about how to re-order objects 
on a label design, see Chapter 6, “Working with Objects.”  

5. On the Tools menu, click ODBC Setup. 
6. On the Connection tab, click Select Data Source. 
7. On the File Data Source tab, click New . 
8. In the list, select the type of ODBC-compliant data source file you are using and then 

click Next. 
9. When prompted for the location and file name of the data source file, click Browse. 
10. Navigate to the folder and select the file and then click Save. 
11. Click Next. 
12. When prompted to create the data source, verify the file type matches the driver type 

and then click Finish. 
13. In the ODBC Microsoft Setup dialog box, click Select Workbook if your data source 

file is Microsoft Excel workbook, or click Select if your data source file is Microsoft 
Access database. 

14. Select the data source file and then click OK. 
15. Click OK again. 
16. When prompted for a DNS name, select the data source file name and then click OK. 

Note:  This links the label design to the data source file, which is retained any time 
you export the label design. 

17. Map the objects on the label design to variable data in the data source file. 
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M a p p i n g  O b j e c t s  t o  V a r i a b l e  D a t a   
Once you link a label design to an ODBC-compliant data source file, the next step is to 
map the objects on the label design to variable data in the data source file.  You must 
specify the trigger object, along with objects that are the key and target objects.  For 
information about specifying the trigger object, see “Adding the Trigger Object to Label 
Designs” earlier in this chapter. 
The order in which you map objects to variable data does not matter.  As long as you map 
each object that requires variable data to the data source file, PCMate can perform the 
lookup when creating print jobs.  

To Map Objects to Variable Data in an ODBC-Compliant Data Source File 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module.  
3. Open the label design. 
4. Add the objects, and specify the trigger object on the label design. 
5. Link the label design to the ODBC-compliant data source file. 
6. On the Tools menu, click ODBC Setup. 
7. On the Connection tab, click Select Data Source. 
8. Find and select the data source file name and then click OK. 

Note:  On the File Data Source tab, you can search in a specific location.  On the 
Machine Data Source tab, you can search for a specific f ile type or driver 
type. 

9. On the Connection tab, click Add. 
10. When prompted to select a library, click the sheet if the data source file is Microsoft 

Excel workbook or the table if the data source file is Microsoft Access database. 
11. Select the sheet or table that contains the data you want to map to the objects on the 

label design. 
Note:  PCMate can only link to one sheet (tab) in Microsoft Excel workbook.  If your 

data is on several sheets, you must link the sheets in your Microsoft Excel f ile.  
In the same way, PCMate can only link to one database table in Microsoft 
Access database.  If your data is in several tables, you must link the tables in 
your Microsoft Access database.  

12. On the Field Properties tab, click Add. 
13. From the Design Field list box, select the first object you want to map to the data 

source file. 
Note:  We recommend mapping the key and target objects first and ending with the 

trigger object. 
14. From the Table Field list box, select the column name you want to map to the object 

selected in the Design Field list box. 
15. If the object is a key object, select the Key Field checkbox.  If the object is the trigger 

object, select the Trigger Lookup checkbox. 
16. Click OK. 
17. Repeat steps 11–16 for each object you want to map. 
18. Click OK. 
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W O R K I N G  W I T H  M A C R O  L O O K U P S  
You can create macros for PCMate to perform lookups of variable data for print jobs. 
Printer operators can manually initiate lookups to input data.  PCMate automatically 
performs lookups when the auto-import and auto-print functions run.  Running a macro 
lookup retrieves data from a macro .XMA file, which resides in the following working 
directory: 
C:\Paxarwin\Macros\[MACRO NAME].XMA 

In this chapter, you can learn about macro lookups, about the Macro Editor and how to 
♦ create label designs that support macro lookups. 
♦ create macros. 
♦ edit macros. 
♦ duplicate macros. 
♦ import and export macros. 
♦ delete macros. 
♦ print hard copies of macros. 

A b o u t  M a c r o  L o o k u p s  
If you want to look up data from a macro, you must designate the objects that are part of 
the lookup on the label design.  The table below provides a description of the three types 
of objects required for data lookups.  
 
Type Description 

Target objects In a print job, a target object becomes a target f ield in which PCMate 
populates data after performing a lookup.  A label design can have 
multiple target objects. 

Key objects In a print job, a key object becomes a key f ield in which the printer 
operator or the Auto-Import Routine inputs a text value that l inks to 
variable data required for one or more target f ields.  A label design can 
have multiple key f ields.  Also, a key f ield can be designated as a target 
f ield in which PCMate overwrites the key during the lookup. 

Trigger object In a print job, the tr igger objects becomes the trigger f ield that executes 
the data lookup – using key f ields to populate data in target f ields. 

 
A label design can include a combination of objects that do and do not require variable 
data from the macro database.  For a single label design, there can be multiple key and 
target objects on any side of the label.  However, you can only have one trigger object.  
To ensure that PCMate looks up the data for all key fields, the order of the trigger object 
should be positioned after all key objects (from left to right).  Otherwise, the lookup may 
miss key fields in the source file and return no values in the target objects. 
Once you create a label design, the printer operator needs know which fields are key 
fields, target f ields, and the trigger f ield.  PCMate does not look up the data until the 
printer operator or the Auto-Import Routine inputs text values in the key fields and 
perform the lookup using the trigger f ield.  
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A b o u t  t h e  M a c r o  E d i t o r  
PCMate has a macro database and a form-style editor that displays each macro 
individually.  Using the Macro Editor, you can navigate through the macro database to 
create, edit, duplicate and delete macros. 

   
Each row in a macro represents a data value.  Each macro can have up to 100 data 
values.  When you create a macro, you must assign a key to the macro for identif ication 
and for the printer operator to input to look up the data values.  On the title bar of the 
Macro Editor, the name of the current macro table you are viewing appears [In Brackets].  
As illustrated in the figure above, the key for the current macro is 100.  For PCMate to 
look up and populate target f ields, the printer operator must enter 100 in the key field and 
then use the trigger f ield to execute the lookup. 
At the bottom of the Macro Editor is a status bar that provides information about the 
current macro.  The left side of the status bar usually displays the word Ready, informing 
you that the Macro Editor is waiting for input.  In the middle, you can see the data value 
that is currently selected within the current macro, as well as how many data values are 
contained in the macro.  This display is of the form "X of Y", where X is the currently 
selected data value, and Y is the maximum number of data values in a macro (currently 
100).   
The Macro Editor has its own set of commands that you can access on the main menu 
and toolbar.  The table below provides a description of the toolbar commands that you 
can access on the Macro Editor toolbar.  If a toolbar button is inactive (grayed out), the 
command may not be available.  Most of the commands on the toolbar are also available 
from the main menu. 

 
 
Button Command Description 

 Create new macro Click this button to create a new macro. 

 Open existing 
macro 

Click this button to open an existing macro. 

 Save current macro Click this button to save all of the changes you have made to 
the current macro. 
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Button Command Description 

 Switch to the 
Design Module 
editor 

Click this button to close the current macro and switch from the 
Macro Editor Module to the Label Design Module. 

 Switch to the print 
module 

Click this button to close the current macro and switch from the 
Macro Editor Module to the Print Module. 

 Show print preview Click this button to open Print Preview. 

 Duplicate the 
current macro 

Click this button to create a new macro that is exactly l ike the 
current macro. 

 Delete the current 
macro 

Click this button to delete the current macro. 

 Go to previous 
macro 

Click this button to display the previous macro in the database.  
If unsaved changes exist in the current macro, PCMate prompts 
you to save f irst. 
Note: Macros are arranged in the database in alphabetical 

order of their keys. 

 Go to next macro Click this button to display the next macro in the database.  If 
unsaved changes exist in the current macro, PCMate prompts 
you to save f irst. 
Note: Macros are arranged in the database in alphabetical 

order of their keys. 

 Go to specif ic 
macro 

Click this button to use the search and replace function within 
the macro database. 

 
In addition to the toolbar, there are also shortcut keys that you can use to bypass the 
normal routine of selecting commands from the Macro Editor menu or toolbar.  The table 
below provides a list of keyboard shortcuts you can use.  For each shortcut, the menu 
navigation appears in parentheses. 
 
Key Description 

F3 Create a new macro (Macro>New) 

F4 Go to a specif ic macro (Edit>Find) 

F5 Duplicate the current macro (Edit>Duplicate) 

F6 Delete the current macro (Edit>Delete) 

F7 Go to the previous macro in the database (Edit>Previous) 

F8 Go to the next macro in the database (Edit>Next) 

F9 Save the existing macro (Macro>Save) 
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C r e a t i n g  L a b e l  D e s i g n s  t h a t  S u p p o r t  M a c r o  L o o k u p s  
If you want to create a label design that supports lookups from the macro database, you 
must designate which objects on the label design are the key, target, and trigger objects. 
It is critical that the order of the target objects on a label design match the data values in 
the macro so that the fields are populated correctly.  For example, if you add three target 
objects to a label design: Price, Size, and Color.  The data values in the macro must 
appear in the same order with the value for Price being in the first row, the value for Size 
being the second row, and the value for Color being the third row.  

To Add the Objects that Support Macro Lookups to a Label Design  
1. Open PCMate, and log on if required. 
2. On the Window menu, click Design Module. 
3. Create or open a label design.  
4. On the Object menu, click the type of object you want to add. 

Note:  If you add multiple key objects to the label design, make sure the trigger object 
appears after all key objects so that when PCMate performs the lookup, it 
retrieves data for all key fields.  For information about how to re-order objects 
on a label design, see Chapter 6, “Working with Objects.” 

5. In the Properties dialog box, click the Field Tag tab. 
6. In the Macro frame, select the checkbox that applies to the object.  

Note:  An object can be all three: a key object, a target, and a trigger object.  
7. In the Field Security frame, select the Display/Editable Field checkbox. 

Note:  If you are adding a non-print object, you should select the Display/Editable 
Field checkbox so that the printer operator can see the field when opening a 
print job.  Selecting this checkbox only makes the field viewable in an open 
print job and not on your label design. 
If you are adding a print object, you may want to select the Editable Only 
Before Library Lookup checkbox and set the Editable by User Level f ield to 
3 to prevent the printer operator from editing the field in an open print job.  

8. On the File menu, click Save. 

C r e a t i n g  M a c r o s  
For every macro you create, PCMate automatically creates an .XMA file in the following 
working directory: 
C:\Paxarwin\Macros\[MACRO NAME].XMA 

You can create any number of macros in the macro database.  For each macro you 
create, you can add up to 100 unique data values.  

To Create a Macro 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Macro Editor.  
3. On the Macro menu, click New . 
4. On each row in the macro, enter a data value. 

Note:  The order of data values in the macro must match the order to target objects 
on the label design for the data to be populated in the correct f ields. 

5. On the Macro menu, click Save. 
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6. In the Enter Macro Key text box, enter a unique key for the macro. 
Note:  The key may not contain blanks, and must be between 1 and 30 uppercase 

characters, inclusive.  
7. Click OK. 

E d i t i n g  M a c r o s  
At any time after you create a macro, you can edit the data values in the macro.  
However, you cannot change the macro key.  If you want to change the macro key, you 
should save your changes as a different macro with a different key.  

To Edit a Macro 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Macro Editor.  
3. On the Macro menu, click Open. 
4. Enter or select the key for the macro you want to open and then click OK. 
5. Edit the macro table as needed. 

Note:  If you want to select the font for a data value, select the row.  On the Field 
menu, click Font.  Configure the font characteristics and then click OK. 
If you want to reverse the input direction of the text in the object, select the 
row.  On the Field menu, click Reverse Input Direction.  To return the input 
direction to normal (from left to right), click Reverse Input Direction again to 
remove the checkmark. 

6. On the Macro menu, click Save. 
7. In the Enter Macro Key text box, enter a unique key for the macro. 
8. Click OK. 
9. On the Macro menu, click Close. 

D u p l i c a t i n g  M a c r o s  
You can create an exact duplicate of the current macro.  If you duplicate a macro, you 
must specify a new key before it can be saved.  

To Duplicate a Macro 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Macro Editor.  
3. On the Macro menu, click Open. 
4. Enter or select the key for the macro you want to duplicate and then click OK. 
5. On the Edit menu, click Duplicate. 
6. On the Macro menu, click Save. 
7. In the Enter Macro Key text box, enter a unique key for the macro. 
8. Click OK. 
9. On the Macro menu, click Close.  
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I m p o r t i n g  a n d  E x p o r t i n g  M a c r o s  
These options are no longer active.  As illustrated below, if you want to import or export a 
macro, you must move the .XMA file manually. 

 

D e l e t i n g  M a c r o s  
At any time, you can a macro from the macro database.  

To Delete a Macro 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Macro Editor.  
3. On the Macro menu, click Open. 
4. Enter or select the key for the macro you want to delete and then click OK. 
5. On the Edit menu, click Delete. 
6. When prompted to delete the current macro, click Yes. 

P r i n t i n g  H a r d  C o p i e s  o f  M a c r o s  
At any time, you can send the current macro to the default Windows printer. 

To Print a Hard Copy of a Macro 
1. Open PCMate, and log on if required. 
2. On the Window menu, click Macro Editor.  
3. On the Macro menu, click Open. 
4. Enter or select the key for the macro you want to print and then click OK. 
5. On the Utility menu, click Hard Copy. 
6. Configure the printer options and then click OK. 
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